Why would one injector spray and the other not on my 1989 k1500 5.7

Asked by Jan 04, 2017 at 07:58 PM about the 1989 Chevrolet C/K 1500 Silverado Standard Cab SB 4WD

Question type: General

2 Answers

73,775

Just a bad injector, probably plugged, just double check that there is voltage at the plugin on top of the injector. Otherwise just replace both injectors.

100,385

Could be a bad a injector, or the injector driver for that injector, you need to test for both power an trigger signals at the injectors, if you loose either of these the injector will not flow, If you have power but no trigger then trace the trigger wire for a short, if none are found the check the signal right at the ECM if no signal exists then it it the ECM.

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    3,600
  • #2
    John Saffrahn
    Reputation
    2,570
  • #3
    Rowefast
    Reputation
    2,170
View All

Related Models For Sale

Used GMC Sierra 1500
265 Great Deals out of 10,821 listings starting at $2,995
Used Ford F-150
470 Great Deals out of 10,109 listings starting at $3,450
Used Chevrolet S-10
8 listings starting at $5,495
Used Chevrolet Camaro
3 Great Deals out of 814 listings starting at $12,995

Used Cars For Sale

1998 Chevrolet C/K 1500 For Sale
2 listings starting at $5,999

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.