No power Running to my engine

Asked by Apr 19, 2017 at 09:18 PM about the 1996 Chevrolet C/K 2500

Question type: Maintenance & Repair

I have a 96 Chevy C2500. I have already replaced
the battery, fuel pump, gaskets,spark plugs, egm ,
checked fuses, complete tune up. I finally got it
running but when I drive it and accelerate, it doesn't
seem to accelerate as much as it should. Any
ideas on what this might be??

2 Answers

31,635

i dont see fuel filter and or pressure at the intake.... or cat.. .converter pressure in and out of that also ,....in your list

1 people found this helpful.

@Kelly, yes those have been checked and replaced also. And there was a typo in my list. It's not EGM it's the EGR Valve that I replaced last. I can't figure out what it could be.

Your Answer:

Chevrolet C/K 2500 Experts

  • #1
    Rowefast
    Reputation
    340
  • #2
    COMETGUY61
    Reputation
    220
  • #3
    Andrew Olsen
    Reputation
    150
View All

Related Models For Sale

Used Dodge Ram 2500
4 Great Deals out of 81 listings starting at $2,975
Used GMC Sierra 2500
8 listings starting at $3,995
Used Ford F-250
1 listing
Used GMC Sierra 1500
80 Great Deals out of 11,043 listings starting at $4,499
Used Ford F-150
119 Great Deals out of 11,225 listings starting at $369

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.