cooling fans not running on a 2001 pontiac montana

Asked by Jan 26, 2017 at 09:42 PM about the 2001 Pontiac Montana Base Extended

Question type: Maintenance & Repair

The car was giving a 0128 code. Replaced the thermostat because it was stuck open. Also replaced the temperature sending unit in the thermostat housing. The gauge reads the temperature but when it goes over 220 the fans will not come and run. If I disconnect the sensor wire the fans will run but the gauge does not show temperature. Replaced the fan relay. When I turn the A/C on high the fans do not run either they used to. Is the coolant level sensor causing the problem. Need help

2 Answers

75,755

Sounds like the coolant temperature sensor. Replace it with an AC Delco sensor. For some reason many aftermarket sensors don't work well or at all in these GMs. HTH. -Jim

Where is the connector plug located

Your Answer

Pontiac Montana Experts

  • #1
    Countrygal77
    Reputation
    2,140
  • #2
    Robert Reed
    Reputation
    1,550
  • #3
    Jim Space
    Reputation
    810
View All

Related Models For Sale

Used Honda Odyssey
22 Great Deals out of 947 listings starting at $2,500
Used Chrysler Town & Country
29 Great Deals out of 471 listings starting at $3,777
Used Dodge Caravan
70 listings starting at $3,900
Used Dodge Grand Caravan
229 Great Deals out of 11,921 listings starting at $3,495
Used Toyota Sienna
22 Great Deals out of 923 listings starting at $2,899
Used Chevrolet Tahoe
5 Great Deals out of 982 listings starting at $7,600
Used Dodge Durango
102 Great Deals out of 984 listings starting at $3,499
Used Jeep Grand Cherokee
134 Great Deals out of 4,061 listings starting at $2,595
Used Ford F-150
577 Great Deals out of 9,694 listings starting at $2,295

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.