1993 Mercury Tracer 1.9L

Asked by Apr 02, 2017 at 03:35 PM about the 1993 Mercury Tracer 4 Dr LTS Sedan

Question type: Maintenance & Repair

Bought a '93 Trader 1.9L from salvage who said the
fuel pump needed replaced as well as timing belt.
Replaced both and car won't run. I can blow in the
line from the pump and it'll come out at the filter,
can blow through the filter as well as the fuel rail.
Any suggestions on where the problem is and how to
fix it?

2 Answers

74,565

Does the fuel pump run when the key is turned on? If not check relay and fuse.

1 of 1 people found this helpful.
69,485

Was the timing belt broken? If so the valves may be bent. Are you sure you lined up everything correctly when you did the timing belt? Try spraying some starting fluid down the throttle body. It should run a few seconds on that. If not check for spark. If you have spark and it won't run a few seconds on the starting fluid it's time to do a compression test. If all cylinders test very low or zero, the valves are damaged or the timing belt was not installed correctly. Also check in the trunk for a fuel inertia cut off switch. This kills the fuel pump in the event of an accident. It may have been tripped by a sudden panic stop. HTH. -Jim

Your Answer

Shortcuts

Mercury Tracer Experts

  • #1
    kbro
    Reputation
    120
  • #2
    tennisshoes
    Reputation
    70
  • #2
    COMETGUY61
    Reputation
    70
View All

Related Models For Sale

Used Ford Escort
2 listings

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.