Crank but no start

Asked by Jul 03, 2017 at 03:26 PM about the 1994 Chevrolet C/K 1500 Cheyenne Standard Cab SB

Question type: Maintenance & Repair

I have 94 Chevy c1500 5.7 tpi. .... just
changed fuel pump filter .. thottle control
sensor... air idle control sensor ... tempature
sensor the one to computer ... and I turned it
off one day went to start it back and cranks
but no start I pulled number one wire and
there is no spark I changed ignition coil still
no spark coming out of wire need help

1 Answer

865

My initial thoughts are possible crank sensor issue. They can be ohm tested if in doubt. Other thoughts are icm unless you did that already. I am leaning towards crank sensor. Good Luck!

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    3,550
  • #2
    John Saffrahn
    Reputation
    2,550
  • #3
    Rowefast
    Reputation
    2,150
View All

Related Models For Sale

Used GMC Sierra 1500
235 Great Deals out of 10,481 listings starting at $2,995
Used Ford F-150
444 Great Deals out of 9,123 listings starting at $3,000
Used Dodge Ram 1500
52 Great Deals out of 530 listings starting at $2,995
Used Toyota Tacoma
34 Great Deals out of 795 listings starting at $5,995
Used Chevrolet Tahoe
5 Great Deals out of 645 listings starting at $6,871
Used Chevrolet Camaro
783 listings starting at $12,995
Used Chevrolet S-10
14 listings starting at $3,800

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.