Crank but no start

Asked by Jul 03, 2017 at 03:26 PM about the 1994 Chevrolet C/K 1500 Cheyenne Standard Cab SB

Question type: Maintenance & Repair

I have 94 Chevy c1500 5.7 tpi. .... just
changed fuel pump filter .. thottle control
sensor... air idle control sensor ... tempature
sensor the one to computer ... and I turned it
off one day went to start it back and cranks
but no start I pulled number one wire and
there is no spark I changed ignition coil still
no spark coming out of wire need help

2 Answers

895

My initial thoughts are possible crank sensor issue. They can be ohm tested if in doubt. Other thoughts are icm unless you did that already. I am leaning towards crank sensor. Good Luck!

65

either a bad coil? how many miles? how old is the battery? when was last tune up? i know when it rains out if you have bad wires and cap & rotor will all need replaced. that should just be the TBI throttle body injection, injector in a carb. so you should have 1 coil cap and rotor

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    3,720
  • #2
    John Saffrahn
    Reputation
    2,600
  • #3
    Rowefast
    Reputation
    2,200
View All

Related Models For Sale

Used GMC Sierra 1500
252 Great Deals out of 10,629 listings starting at $1,775
Used Ford F-150
531 Great Deals out of 10,064 listings starting at $1,800
Used Dodge Ram 1500
45 Great Deals out of 520 listings starting at $2,997
Used Chevrolet Tahoe
4 Great Deals out of 739 listings starting at $6,935
Used Chevrolet Camaro
3 Great Deals out of 838 listings starting at $12,907
Used Chevrolet S-10
11 listings starting at $5,950
Used Toyota Tacoma
39 Great Deals out of 1,006 listings starting at $5,850

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.