check engine light was on. ran fine. codes pointed to bank one

Asked by Feb 05, 2017 at 02:43 PM about the 2006 Hummer H3 4dr SUV 4WD

Question type: Maintenance & Repair

I replaced the O2 sensor. The light went off for a couple days and came back
on with the same code. I replaced the other O2 sensor. Light stayed off for
two days and is back on. Code is bank 1 issue still. What else can I check

1 Answer

85,945

Do you have an exhaust system leak?

Your Answer

Hummer H3 Experts

  • #1
    HummerGirl
    Reputation
    840
  • #2
    cocod
    Reputation
    830
  • #3
    PatriciaDoss
    Reputation
    660
View All

Related Models For Sale

Used Hummer H2
23 listings
Used Jeep Wrangler Unlimited
131 Great Deals out of 3,938 listings starting at $599
Used Jeep Wrangler
116 Great Deals out of 2,036 listings starting at $3,995
Used Ford F-150
658 Great Deals out of 10,075 listings starting at $2,995
Used Chevrolet Tahoe
3 Great Deals out of 746 listings starting at $3,995
Used Cadillac Escalade
6 Great Deals out of 479 listings starting at $4,980
Used Chevrolet Silverado 1500
196 Great Deals out of 10,079 listings starting at $1,995
Used Toyota Tacoma
49 Great Deals out of 1,113 listings starting at $7,950
Used Toyota 4Runner
10 Great Deals out of 550 listings starting at $2,254
Used Toyota FJ Cruiser
67 listings starting at $10,388
Used Jeep Grand Cherokee
150 Great Deals out of 3,605 listings starting at $3,500
Used Land Rover Range Rover Sport
15 Great Deals out of 241 listings starting at $12,888

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.