Sputtering Backfire - Chevy S10 with a Blazer 4.3 V6 engine

235

Asked by Aug 09, 2016 at 10:12 AM about the 2002 Chevrolet S-10 LB RWD

Question type: Maintenance & Repair

Hi guys, I have a 1994 Chevy S10 that has a 2002 Blazer 4.3 V6 vortex
Engine in it. This morning on the way to work as I was going up an on-ramp
(uphill) to get on the highway, the truck began to sputter and seemed like it
was having a lack of power. Once on the highway there was a significant
change in the power and it began to sputter (especially in the first few
gears). While on the highway the engine light (which is always on probably
due to the fact that they put a different engine in the truck and it didn’t all
line up), started to flash. Then it went back solid again. Once I got off the
exit and was stopped at the red light, it began sputtering again and then
backfired slightly a few times. I made my way to my destination with
sputtering and a few small backfires (in the first few gears). Seems to have
the most trouble when stopped at light in drive idling and first few gears.
Then will drive fine but you can tell that it doesn’t have the same power.

I then took the truck to a gas station filled it up with premium (it was at
about ¼ of a tank before). Let it idle for 10-15 minutes and went to work.
Along the way same thing. Most of the sputtering and small backfire
sounds came mostly when stopped at light and going first few gears.

Note: there was some heavy rain yesterday and the truck is a bit low. I did
go through a few puddles yesterday on the way to work in the am. Never
noticed any changes after the puddles (about 10-15 minutes to my work). It
sat all day at work drove home just fine yesterday. No issues. Sat all night
then this morning drove it for 2-5 minutes before getting on the highway
and noticing the sputtering.

I checked the air filter and it is completely dry along with the inside of the
air filter container. My friend said it might be something to do with the wiring
and I might be able to see a spark if one of the wires is loose or not
connected properly. Not sure.

Any help would be greatly appreciated. Thank you!

4 Answers

235

Here's a picture of the engine

235

Here are the error codes:

235

Here are the codes after I cleared it

2 people found this helpful.
235

And this is what they said to replace first

4 people found this helpful.

Your Answer:

S-10

Looking for a Used S-10 in your area?

CarGurus has 6 nationwide S-10 listings and the tools to find you a great deal.

Postal Code:

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    5,780
  • #2
    Js08016
    Reputation
    2,140
  • #3
    Trebor66
    Reputation
    2,040
View All

Find great deals from top-rated dealers

Search

Related Models For Sale

Used Chevrolet Silverado 1500
130 Great Deals out of 12,593 listings starting at $3,995
Used Ford Ranger
10 Great Deals out of 1,059 listings starting at $3,500
Used GMC Sonoma
4 listings
Used Toyota Tacoma
41 Great Deals out of 1,747 listings starting at $5,500
Used Ford F-150
278 Great Deals out of 14,160 listings starting at $1,377
Used Chevrolet Blazer
1,133 listings starting at $34,888
Used GMC Sierra 1500
104 Great Deals out of 11,009 listings starting at $3,000
Used Dodge Dakota
115 listings starting at $2,995
Used Nissan Frontier
36 Great Deals out of 771 listings starting at $2,950
Used Dodge Ram 1500
11 Great Deals out of 360 listings starting at $3,500
Used Chevrolet Camaro
38 Great Deals out of 1,087 listings starting at $9,950

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.