When I apply a jumper the car still won't start

Asked by Mar 30, 2017 at 02:32 PM about the 1999 BMW Z3 2.8 Roadster RWD

Question type: Maintenance & Repair

When I apply jumper cables from another car the Z still won't start and keeps clicking just like when the battery is dead.  All electrical turns on but it appears that it still is not getting enough electricity

2 Answers

96,325

Bad starter or bad battery connections - clean and tighten the battery cable ends. A battery with an internal short can make it hard to jump start the car.

24,715

sounds like a starter solenoid- if you keep "applying" jumper cables to your BMW you are going to fry some electronics in there- then all bets are off-

Your Answer

BMW Z3 Experts

  • #1
    Tom Demyan
    Reputation
    430
  • #2
    Kelly Mayo
    Reputation
    250
  • #3
    Sleveillee
    Reputation
    230
View All

Related Models For Sale

Used BMW Z3 M
2 listings
Used Mazda MX-5 Miata
4 Great Deals out of 237 listings starting at $6,795
Used BMW 3 Series
154 Great Deals out of 2,215 listings starting at $2,000
Used Porsche Boxster
59 listings starting at $10,900
Used Chevrolet Corvette
518 listings starting at $9,900
Used Ford Mustang
998 listings starting at $3,900
Used BMW M3
87 listings starting at $17,491
Used Mercedes-Benz SLK-Class
82 listings starting at $4,980
Used Porsche 911
207 listings starting at $37,995
Used Honda S2000
13 listings starting at $15,499

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.