I have a 2007 Mercury Monterrey with 4.2L and it stalls almost every day when first started and put into gear forward or reverse. Once warmed up it appears to be ok. No codes !!!!

Asked by Feb 16, 2016 at 02:32 PM about the 2007 Mercury Monterey Luxury

Question type: Maintenance & Repair

I have a 2007 Mercury Monterrey with 4.2L and it stalls almost every day
when first started and put into gear forward or reverse. Once warmed up it
appears to be ok. No codes !!!! I already had one mechanic look at it and fuel
pressure ok as well as contracts and relays ok. He removed main computer
line and cleaned and put dielectric grease on terminals. I already tried the
MASS air flow sensor and idle control and fuel filter and air filter. I cleaned the
throttle body and checked vacuumed lines. Also there is an intermittent pop
sound from inside air inlet or at least you can hear it from air cleaner area as it
gets magnified. Other than that car runs and shifts fine after warm up. Very
strange and annoying . What the hell could this be !!!!! HELP !

7 Answers

38,760

Did you replace the fuel filter ? And add some seafoam fuel injector cleaner to gas tank.

1 people found this helpful.

Yes tried both

38,760

When was last time you had a tune up popping noise you hear could be a spark plug miss firing.

I changed plugs last summer and wires

38,760

Does your vehicle have electronic throttle or cable throttle ? Sounds like throttle is staying open all the time instead of slightly closing when cold and opening slowly as vehicle warms up. If you have a cable throttle may have to adjust throttle if electronic throttle may have to replace.

1 people found this helpful.

It is a cable control. In my mind I am thinking coil pack or electrical . Engine dies fast just after a slight rough idle again only in gear. Happened again this morning. I let it die 3 times then once it got to a stable point it will run fin in gear. I appreciate the advice. I am willing to try anything to get this fixed. Last summer the check engine light did come on and code said plug 3 no good or wires or coil pack. I replaced plugs and wires and light went off. However maybe coil pack was still an issue .

Did you ever find the answer. I have a 2007 Mercury Montego that does the same. Have had everything changed out it seems and it is still acting like it has run out of fuel while I am driving and just stops. Mechanics can't figure it out either.

Your Answer:

Monterey

Looking for a Used Monterey in your area?

CarGurus has thousands of nationwide listings and the tools to find you a great deal.

Postal Code:

Shortcuts

Mercury Monterey Experts

  • #1
    gws
    Reputation
    160
  • #2
    kbro
    Reputation
    100
  • #3
    badgeboy
    Reputation
    80
View All

Find great deals from top-rated dealersTM

Search

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.