What could be the problem? HELP ME PLEASE!

Asked by Dec 29, 2016 at 12:32 PM about the 1991 Oldsmobile Eighty-Eight Royale 4 Dr STD Sedan

Question type: Car Customization

I have a 91 old 88 royae. I had an issue with the harmonic balancer and had it
replaced. Since then im having issues cranking it up initially. When I first go out
to crank it, the engine turns over, jumps, and makes a backfiring sound but
won't crank. After maybe three attempts the vehicle will crank but runs as it its
skipping. Then while I'm driving, initially, there is no problem but once the
vehicle warms up, it begins to accelerate extremely slow, jumps sometimes
while accelerating, and makes a grinding or whining sound only when I press
the accelerator and when I ease off the accelerator it stops. I have no ideal
what the problem could be. Can someone please help me??

2 Answers


It needs to go to an experienced mechanic for proper diagnosis. There is really not enough information here to make the determination as to what is wrong.

1 of 1 people found this helpful.

The crankshaft position sensor or it's wiring probably got damaged when the harmonic balancer was replaced. Is the service engine soon or check engine light on? HTH. - Jim

Your Answer

Oldsmobile Eighty-Eight Royale Experts

  • #1
    Michael Urbanski
  • #2
    John Saffrahn
  • #3
    Tom Demyan
View All

Related Models For Sale

Used Buick LeSabre
9 listings starting at $3,795
Used Lincoln Town Car
13 listings starting at $1,850
Used Chevrolet Camaro
1,085 listings starting at $12,995
Used Ford F-150
551 Great Deals out of 10,128 listings starting at $3,490
Used Buick Regal
214 listings starting at $8,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.