I have replaced the motor mount on my 2003 buick century twice, along with the cv axil, lower control arm, and wheel bearing on the passenger side and the car is still squeeking and not handling right, what else could it be?

Asked by Jun 08, 2017 at 09:42 PM about the 2003 Buick Century Base

Question type: Maintenance & Repair

2 Answers

2,785

Was the motor mount oily ? For these things to be related I think the problem is serious , A professional shop with the right equipment can set your alignment and camber , unless you see an obvious problem those are things you can't generally do in the driveway , unless you're chuck norris .

Thank you

Your Answer

Buick Century Experts

  • #1
    John Saffrahn
    Reputation
    970
  • #2
    Tom Demyan
    Reputation
    800
  • #3
    John Pate
    Reputation
    560
View All

Related Models For Sale

Used Buick LeSabre
13 listings starting at $4,395
Used Buick Regal
11 Great Deals out of 269 listings starting at $6,995
Used Chevrolet Impala
149 Great Deals out of 1,050 listings starting at $997
Used Honda Accord
88 Great Deals out of 908 listings starting at $1,411
Used Toyota Camry
90 Great Deals out of 2,273 listings starting at $1,781
Used Chevrolet Malibu
91 Great Deals out of 2,040 listings starting at $2,994
Used Ford F-150
523 Great Deals out of 10,148 listings starting at $1,800
Used Audi A4
35 Great Deals out of 600 listings starting at $1,895
Used Ford Focus
88 Great Deals out of 2,604 listings starting at $999
Used Lexus ES 300
7 listings starting at $4,950

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.