Explorer going crazy since reconnecting battery

Asked by Nov 22, 2017 at 06:28 PM

Question type: Maintenance & Repair

I disconnected my battery, didn't touch
anything else...  When  I reconnected it the
lights start blinking,  the car won't start and
do it won't stop  making that ping noise like
if I left the lights on....  What do I do and why
is this happening?

2 Answers

104,125

Did you reverse polarity?

113,665

You didn't state what year but this sounds like a security issue, have you performed the shut down procedure listed in the owners manual? If you don't have an owners manual get one, sometimes you can find them in PDF format online. You can also try this: battery connected, from inside manually lock the doors except the drivers, with key in hand exit the vehicle close the drivers door and using the key manually lock the drivers door, that should have made all the lights and stuff stop, if it didn't then this procedure will not work and you will have to do what the manual suggests. now if the procedure in the owners manual does not work then you have a fault in the security system hardware and that will have to be checked out by someone who knows this system.

Your Answer

Shortcuts

Maintenance & Repair Experts

  • #1
    Tom Demyan
    Reputation
    200,080
  • #2
    dandyoun
    Reputation
    101,250
  • #3
    tennisshoes
    Reputation
    88,960
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.