96 Lexus LS400 w/205k miles, car starts, won't shift, no dash lights, windows and sunroof and radio don't work

Asked by May 17, 2018 at 08:10 AM about the 1996 Lexus LS 400

Question type: Maintenance & Repair

I have a 1996 Lexus LS400 with 205k miles. Yesterday morning, it drove just
fine. Got home, parked and came back 4 hours later and it started, but I have
no lights on my dashboard (except a battery light), the radio doesn't work, the
antenna's not coming up, windows and sunroof don't work, and the car will
not shift out of park. Headlights come on manually, but not auto. Tail
lights/brake lights all work. Checked fuses, all fuses have been green-lighted.
Any help to figure this out would be appreciated. Thank you.

1 Answer

20

You may have burnt fuses.

Your Answer:

Shortcuts

Lexus LS 400 Experts

  • #1
    dandyoun
    Reputation
    250
  • #2
    COMETGUY61
    Reputation
    220
  • #3
    littlehorn
    Reputation
    200
View All

Related Models For Sale

Used Lexus GS 300
7 listings starting at $6,995
Used Toyota Camry
43 Great Deals out of 1,907 listings starting at $100
Used Lexus ES 300
8 listings starting at $2,000
Used Honda Accord
40 Great Deals out of 1,625 listings starting at $1,995
Used Mercedes-Benz S-Class
11 Great Deals out of 177 listings starting at $7,780
Used Toyota Avalon
14 Great Deals out of 208 listings starting at $4,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.