My temperature garage works sometimes, have already replaced sending unit, but still does it. The odometer is doing same thing. what could problem be?

Asked by Dec 29, 2015 at 07:16 AM about the 1996 Ford Contour

Question type: Maintenance & Repair

1 Answer

69,545

The temp sending unit has nothing to do with the odometer other than the gauge. There should be a fuse to check. The temperature readings you are getting, may be low coolant, bad thermostat, or air pockets in the cooling system.

Your Answer

Add photo

Related Questions

Search Ford Contour Questions

Ford Contour Experts

#1 tropikalpirate
tropikalpirate
Reputation 630
#2 David Koppa
David Koppa
Reputation 330
#3 Wesley Beadle
Wesley Beadle
Reputation 280
View All

Related Models For Sale

Used Ford Taurus
35 Great Deals out of 300 listings starting at $4,988
Used Ford Escort
2 listings
Used Ford F-150
293 Great Deals out of 8,122 listings starting at $2,499
Used Ford Mustang
1,334 listings starting at $5,980
Used Chevrolet Camaro
984 listings starting at $13,999
Used Ford Explorer
38 Great Deals out of 1,198 listings starting at $2,900
Used Toyota Corolla
174 Great Deals out of 3,886 listings starting at $1,995
Used Toyota Camry
53 Great Deals out of 1,641 listings starting at $800

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.