Like to know

Asked by Mar 03, 2018 at 04:24 AM about the 1989 Chevrolet S-10 Blazer

Question type: General

Okay I have an 89 s10 Blazer with a 4.3. it
runs like a champ, but getting it started
seems to take a second or two. If the engine
is warmed up then it starts just fine. I was
told that this could be because of a bad 02
censor. But I'm not sure, so if anyone can
give me advice before I start throwing
money I don't have into this thing.

2 Answers

10,725

turn the key to run position and turn it off , then start it see if that makes a difference , it may not be getting primed to fire up ,

do you have a fuel pressure gauge?

Your Answer:

Chevrolet S-10 Blazer Experts

  • #1
    Cody Doud
    Reputation
    970
  • #2
    emtfirefighter77
    Reputation
    660
  • #3
    Markfisler
    Reputation
    430
View All

Related Models For Sale

Used Chevrolet S-10
5 listings
Used Chevrolet Blazer
209 listings starting at $2,999
Used Chevrolet Camaro
8 Great Deals out of 1,033 listings starting at $10,995
Used GMC Jimmy
14 listings
Used Ford F-150
133 Great Deals out of 9,936 listings starting at $2,000
Used Ford Ranger
5 Great Deals out of 430 listings starting at $1,999
Used BMW 3 Series
119 Great Deals out of 2,263 listings starting at $2,600

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.