Engine Problem

340

Asked by Nosipho May 19, 2009 at 02:55 AM about the 2000 Opel Corsa

Question type: Maintenance & Repair

Year 2000. My car is cutting off and lacks the power it used to have. Recently after a lot of guess work by so-called mechanics, they have put in a semi-new computer box.  Do I have to buy a new engine?

87 Answers

17,475

Find a New Mechanic - Sounds like a basic fuel / spark issue and should be able to be located by a qualified professional Not enough information to help you out here though.

42 people found this helpful.
340

Thanks Mike. I will tey and get more information but some of the work done has been, changing the spark plugs, buying and fitting a new fuel tank etc.. i really dont want to sell my car but it has given me enough trouble to get rid of it.

34 people found this helpful.
765

Hi please dont let fools tell you what THEY THINK IT IS, please, tell me more about your problem, maybe i can give some advise to you! Francois.

76 people found this helpful.
465

The car struggles to start sometimes ?? Sounds to me that it might be a faulty petrol pump or worn out cranck gear on the timing belt. I would rather replace the timing gear and t/belt and tensioner before changing the petrol pump

43 people found this helpful.
760

Hi Francois, you sound like a sensible man, I have an Opel Corsa 1.6IE Classic 4 door year 2000 - it too is cutting out for no reason and we have tried everything from fuel lines to spark plugs and it has been to umpteen mechanics who have not been able to sort the problem out. The other day my husband was running the car without the fuel cap and she would not cut out so we thought it might be a breather problem which he checked and cleaned but still it was cutting out so now I am driving with my fuel cap slightly loose and have had no problems for two weeks but alas yesterday she cut out on me again, I am at my wits end now and am seriously thinking of selling the car - please help me we have tried everything. Could there be water in the fuel, another theory???? - Where is the drain plug for the fuel tank. My email address is Ron.Edward@seedex.co.zw (yes I live in Zimbabwe so you know how frustrating it is here)

76 people found this helpful.
210

Full pum ok comper ok over full. Do staart on full frottel. But do not rev up

21 people found this helpful.
1,170

Hi, same issue with my Corsa lite 2000, replaced crank sensor, bogey's, distributor pack and more. Still cutting out. After replacing crank timing sensor car drove fine for a week, then started to strugle firing up and finally not start at all after a couple of days. Tomorrow I am checking the sensor allignment, if that is fine the last option i can think off is replacing the crank pulley. This i hear is known problem in these model cars....the timing gear/tooth wears down....

52 people found this helpful.
1,170

Me again, crank shaft pulley key groove worn out causing timing to move by 15 degrees....on my way to buy new one...R200 at goldwagen.

36 people found this helpful.
1,170

Replaced the Crank Pulley. Car is starting and running fine.

29 people found this helpful.
100

which Goldwagen would that be...? I parted with R600 for that including the inner one.

10 people found this helpful.
290

I have a 2007 Opel Cora Lite 1.4 in excellent condition. Serviced regularly BUT all of a sudden the fan keeps on going off. So loud that people at an intersection are inclined to stare. Took it to Opel who changed the thermostat and the radiator hose etc but the fan still goes off especially if driving slowly. Very concerned as we were told this was normal.

29 people found this helpful.
770

Hi Johann you seem it be very knowledgeable when it comes to Corsa motors, I have a 2005 1.4 Corsa utility. When I start it it wont rev for about 2 minutes, it has no power and tends to overheat. I have put it onto 2 diagnostic computers and no errors come up. I had an auto electrician check it and he found no problems. He and I together checked the timing and everything lined up. I also replaced the sensor on the crank shaft pulley. The only problem that I know exists is a hole in the exhaust pipe. do you have any idea as to what the cause might be. Thanks Anthony 083 269 8559

46 people found this helpful.
770

Sorry wrong cell number should be 079 326 8668

8 people found this helpful.
550

Hi Johann and Members. I have a 2001 Corsa B with a C14NZ engine. The car idles normally. However, it backfires and struggles for power when attempting to accelerate. On the highway I've resorted to driVing in second gear to make the have some sort of power. When the car is driven the outlet manifold is becoming red glowing hot where the Oxygen sensor is connected. I have recently changed the spark plugs amd wires but this problem continues. Can you give me any guidance on how I can resolive this issue? Thanks Israel

28 people found this helpful.
770

Hi Israel, I have a similar problem, Car lacks power, overheats very easily and wont rev when first started. I have had it analyzed on 3 different occasion with a computer and they find no error codes. Replaced the spark plugs, spark plug leads, crank sensor, throttle positioning sensor, MAP sensor and knock sensor. Checked the timing all perfect. To date have not managed to fix it. I know how you feel.

20 people found this helpful.
550

Hi Anthony. Thanks for your response. It is indeed frustrating. Can anyone advise on resolving this issue with the C14NZ Engine?

4 people found this helpful.
770

H Israel have you had some one connect you car to a diagnostic computer to see if it brings up any errors. If it shows errors then you know what is faulty. Mine does not bring up any errors.

3 people found this helpful.
550

Thank you for the guidance Johann and Anthony. Johann I will add you on Whats app.

5 people found this helpful.
550

Good morning JohAnn, I did a diagnostic on my Corsa B. I got code29- Fuel pump relay low voltage. Can you advise if this could cause the problem I'm having and how I am to fix this issue please?

18 people found this helpful.
250

Dear Johann I drive an Opel Corsa 160is, 1998 hatch model. My spark plugs are getting wet everytime. Any advise on what could be causing it? Thank you. Sidney (061 426 0741)

25 people found this helpful.
100

Hi mine is doing the same if it is could what could be the problem thanks Sandra 0781824938

10 people found this helpful.
160

Hy Johann I have corsa lite is keeping on breaking camshaft please help me thanks simon 0835178099

16 people found this helpful.
670

Hi Johann... I am driving 2002 corsa lite 1.4 engine, now it giving me problem the idle is too high and durring driving it just loos power sometimes switch off whill driving. What might be the problem?

67 people found this helpful.
240

Hi Johann can i have your contact deltail please i need a good mechanic

7 people found this helpful.
240

Hi Guys i have a problem where the engen fan of my Opel Corsa 1.4 lite goes on but very late. Any ideas why its doing that. Kenneth please help

17 people found this helpful.
180

Hi Johann, I'm driving corsa utility 2008 but im experiencing a many problems on it , first it cut off when accelerating today 4rpm what could be the cause?and heavy on fuel consumption

18 people found this helpful.
120

hi Johann , my corsa bakkie swings but it floods the system and over fuels and when i do get it too idle its on a high revv and blows a air sound on intake ,please advise me on where too check .thanks

12 people found this helpful.
50

Don't think its relevant but my corsa started to choke on ignition, sometimes not even starting and dashboard not working whilst driving. After I had a sensor in the engine changed and more spending my mechanic finally found out it was a connection in the dashboard. Been running ok now for the past 6months.

5 people found this helpful.
130

Hi johann .i have a opel corsa clasic 1.6i 2001 .my car is heavy on fuel .and it habe a ping sound i have replaced the spark plugs new coil pack and a cold start sensor.new timming belt ens. can tne problem be the crank sensor o and sometimes my rev fall to 300 and then back to 900

13 people found this helpful.
110

His please help I have a Opel corsa gamma 1,4, it ignites very slow and slowly gains power and when I am driving sometime the dash board just switches off , please help my number is 0636303876 arnoldmille20@gmail.com

11 people found this helpful.
130

Hi Johann Please could you explain to me everytime we change the crank pully the corsa lite bakkie wont start or idle and eventually backfires. We are struggling to get the vehicle starting and idling and running again

13 people found this helpful.
50

Hi Johnn I have a corsa classic 1.4 the problem is the car drives well and suddenly cuts off I checked and found that Petrol fuse is blown and the earth wire at Petrol pump become life I replaced the fuel relay and fuse but after I drive and do about 6 km she blows the fuse and same story all over again it is not a dead short cos if it was it wil blow the fuse when I turn on the ignition but she lets me drive and then she cuts off what can I do my no is 0813105007 my name is Benny I do have whatsup on same no can you help me

5 people found this helpful.
100

Hi Johann I've got a Corsa D 1.4 and it doesn't have power I diagnosed it the fault codes was h20 sensor so I replaced all sensors and oxygen sensor it's still doing the same no power no misfire but it even cuts out while driving and it doesn't go faster than 40km revs also not going higher then 3000rpms what could the problem ve

10 people found this helpful.
160

hi Johann i have a corsa b year 2000 very poor engine performace engine reaches 6000rpm when acceleraing lighty but when fully accelerating engine chokes and backfires in exhaust in intake. engine tends to cut then re accelerate to about 4000 rpm then chokes again and backfires rough idling...would climb and fall nearly undriveable no power at all...has a high smell of fuel after backfire got faults on maf sensor, camshaft sensor, tps, idle air control,oxygen sensor,engine rpm sensor,intake air temperature sensor and also MIL lamp p0650 changed maf sensor and checked the wiring changed oxygen sensor as well checked the other sensors and they seem good except am having a doubt on the idle air control need to check for the MIL fault any idea plz? do you think it may be the ECM?

12 people found this helpful.
160

whats your country code number?

4 people found this helpful.
100

Morning Johan i have corsa gamma 1.4 struggles to start in the morning but during the day its fine also cut off after driving for few minutes start again

10 people found this helpful.
60

Where are you in South Africa

6 people found this helpful.
130

So my corsa gsi 1.6 2001 model will not start....is overfueling.... When it did start it sounded like it was going to cut out and even if I pressed full excelerator it didn't even Rev....i switched it off and then it wouldn't start again...after much deliberation... Screw drivers.... And other things that made no sense to me I was told that the car is pushing out too much fuel (ummmm I could of guessed that from the smell).... Some valve is probably not regulating fuel properly... So apparently we or rather they (mechanics) are going to try re-setting the ECU.... I have no clue if this could be it or if I'm going to be paying a huge bill for nothing....

13 people found this helpful.
130

Hi I am driving astra code 2002 car jerking a bit and idling goes up when engine is hot

4 people found this helpful.
130

Car jerking a bit and idling goes up when engine is hot 2002 1.6 excited 16v

9 people found this helpful.
60

Opel corsa gamma 1.8 petrol injected 2008 Only 2 cylinders firing 1 ,3 and same for injectors. Other two not firing Car starts idles on two cylinders and cuts of No faults on diagnostics shown Any advice Thanks S.S

6 people found this helpful.
90

utility 1.4 there is the engine light that reflect on the cluster than immediately the sound change

3 people found this helpful.
90

utility 1.4 there is the engine light that reflect on the cluster then immediately the sound change. can yuou please assist

6 people found this helpful.
130

Hi Johann, I trust that you are well,can you please assist me with my corsa lite 1996 model, it seems like it smothers when I'm to long in traffic or when its a very sunny day, but in the morning when it's cold it would run perfectly fine..I'd really appreciate your help before I go to anyone that would assume what the problem would be, thanks in advance.

7 people found this helpful.
130

I want to fit an original e46 sunroof to my bmw , where do i connect the harness to ?

2 people found this helpful.
40

Hello I have a 1999 Opel astra station 1.6, time belt snapped while driving and engine turned dead of course. Can anybody tell me if the engine in these models is free running or will have broken or bent valves after the incident... Kind regards Stefan Torfi

1 people found this helpful.
40

I am trying to figure out if my Astra 1.6 mod. 1999 has a free running engine. Of not some valves may have been damaged/bent when the timebelt broke. If that is the case it is not worth fixing... Regards Stefán T.

3 people found this helpful.
40

Hi there Johann I drive an Opel Corsa Utility Bakkie (2007 model). I just got the bakkie and the previous owner stated that his instrument cluster gave him problems so he changed it but the odometer on it is almost double of the kilometres that the car has done. I also wanted to ask. The car misfires when its idling and the engine looks as if its shaking. The other thing is, it releases blue smoke whenever its idling, is it perhaps time to change rings and bearings?

4 people found this helpful.
20

Hi Johann I have 2009 CDTI 1.3 Opel corsa 5 door, it just went off while I was driving and the dash board lights where appearing and took to wesvaal for service and they told me its a wiring problem I have to take it to the electricians, I did so and at the electricians they told me that it is a canvas/canvus problem it needs a dealer. Now am stuck wesvaal it does not want to help me. Please assist me my contacts 0763965007 am residing in rustenburg

2 people found this helpful.
40

Hi Johann I got a 2005 1.8i Corsa bukkie.. When the car is cold it will struggle to start but when i start it again once it has started it starts fine only struggles wen cold what could it be sir

4 people found this helpful.
60

Hi Johann. I trust you are well. I have a opel astra 160i (c16se) that keeps breaking the crankshaft pulley. I've changed it 3 times this far but it breaking the part where the black pulley locates onto (size of a matchstick head). Do you have any tips or tricks to stop this from happening? I was thinking of maybe drilling a hole through the both of them and putting a cirlock pin in the 2 or even welding the 2 together. Do you have any suggestions? Thanks in advance

6 people found this helpful.

Hi Johann just see your experience of cars I have also problem with my car its Daewoo lanos engine its opel 1.6l that car it's stressful putting to much petrol smoking black hot engine fan not running not starting well and battery be fat quickly help me please where can I start

20

Hie Johann I have a problem with my car Astra classic 1.8 16v the car do not want to start I check power on the injectors is there changed the coil park but still the car do not want to start the car was driving when I parked it but did not have power especially on 1 gear wat can be the problem even when I parked the car it had hard start also

2 people found this helpful.
80

Hi there Johann, you seem to know quite a bit about corsa's. Maybe you have an answer for me. I have a Corsa Lite 1.4, 2005 model. 1 - I have the same idle problem, either idles at 500 or lower like its going to cut out. OR it idles at about 2000 and sounds like its going to take off. (I have replaced the idle valve) 2. She jerks when she drives, definite power problem. You can feel her lose power and then thrust power out. (possible air flow meter?) 3. My km's light flickers when I drive. This morning when I switched my lights on, it cut my radio out. So while driving I noticed the flickering on my kilometers light, so I switch off my radio and headlights. But when I switched my headlights back on, it killed my car. The thing in the alternator (Alternator Voltage Regulator) that has been replaced, because it was not charging my battery. Over all the time, I have replaced all my censors, fixed the split in my air pipe, replaced alternator parts, replaced fan belt, water pipe, spark plugs, cables. Its been on 3 diagnostic tests, which tell me my car is 100% and has been to about 8 mechanics. Hopefully you can shed some light. Thank you. nikkistr@gmail.com

8 people found this helpful.
70

Hi Johan, if cambelt breaks on 2003 Corsa 1,6 Sport, will valves be bent? Thanks.

7 people found this helpful.
30

Hi Johan, I drive a 2010 Corsa Sport 1.4, 3 door it is on 176 000Km now. I started the car this morning and all that came out was a blue smoke. Please help

3 people found this helpful.
10

Hi John, I found all your answers to be very helpful Sir, and I'm very glad you are in Gauteng. But where is your workshop? 0795212311

1 people found this helpful.
210

Good day Johan I see you are the one that's really helpful here, no offense to the others lol. I have a Corsa Lite Plus 2006 model. My car has been going for her regular services etc., all of a sudden my car did not want to start properly cutting out while I'm driving (this is when the engine light goes on) and as soon as I put my clutch in the revs drop below right down to zero sometimes it dies while dropping and sometimes the revs go from zero to a thousand again...eventually I took it for diagnostics nothing was found twice I did it, all sensors were replaced as well as the fuel pump relay..coz when I put in petrol it just suddenly drops (the indicator). My speedometer stopped working as well as my clock for the kilometers driven. Oh and sometimes the revs go high and stay there while driving or stopping, as soon as I release only my clutch without using the Escalator then the revs come down. Eventually my car just died and no one could pin point the problem, until I thought it was the tracker I've installed but apparently the unit is fine and it's notting draining power from my car. Then this guy just scratched around and found that the plug was not properly in the unit and just wiggled it back in (see attached pic)...and there!...BOB's your uncle my car finally started!...but the problems mentioned above is still continuing. I need to fix my car as in yesterday already, as I am soon expecting and need a reliable car to get me to hospital. I would appreciate your soonest response.

19 people found this helpful.
10

GuruVVLGG I feel You have a wiring problems in this Toy GF or The TPS is worn out inside from idle position marks up when you begin to accelerate, it start to reach the damaged marks in the circuit board. If You have replaced it before with a used one You might have used another old faulty one. If its brand New wiring might be an issue but Johann is good in this He will advise us both...I am not Mech Guru but an electronic or black box Techie

1 people found this helpful.
50

Hi Johann I have a Chev utility 2011 model very poor engine performace engine reaches 6000rpm when acceleraing lighty but when fully accelerating engine chokes and backfires in exhaust in intake. engine tends to cut then re accelerate to about 4000 rpm then chokes again and backfires rough idling...would climb and fall nearly undriveable no power at all...has a high smell of fuel after backfire got faults.

5 people found this helpful.
40

Hi wondering if anyone can help I drive a Corsa D Black Edition 1.4 turbo (Engine A14NEL) The engine randomly started cutting out about a month ago, garage said they could hear a miss fire so changed coil pack, can ran fine for a couple of days and started to cut out again. I have since changed the crank sensor as I heard that is a common fault, weirdly enough although the car originally cut out when slowing down or setting off this has started happening when driving down the motor way. When the car dies I remove the coil pack connection re-seat it and it starts up every time. There are no Faults on the ECU Any help will be appreciated

4 people found this helpful.
40

Hi guys i need some advice my corsa cuts out and it seems like the revs get stuck it starts fine first timeeverytime and if the revs get stuck i turn then engine of and on and it corrects the issue, i suspect the iac valve;idle air control valve.

4 people found this helpful.
40

Hi Johann. My cambelt snapped leaving me with 4 damaged valves. I drive a 2002 1.4 Corsa utility. The mechanic replaced 4 valves, 3 belts,tensioner 2 rockers,overhauled head., Replaced manifold pressure sensor because idling was very high. My engine light remains on until I press the accelerator also lacks power upon sudden accelerating. The fan came on today, despite being cool day and not stuck in traffic. Towards the end of journey

4 people found this helpful.

Hi Johann It's Patrick,I can see that you are helpfully I've got 1.4 corsa comfort 2002 nd it giving me a problem of power lack when I'm driving on the road that is stippy up but when I'm driving on a level road it doesn't gives a problem but when I slow down the speed it also start loosing power nd it backfire, so I need your help please

Hi All, Have an Opel Corsa B, Registered September 2000. I drove it fine for a few months, no problems and after starting it up (had gone out and car had been driven, left it for 10 minutes off and came back to it) the car just seemed to idle low and cut out. It did this alot! I disconnect sensor after sensor and after multiple times swearing at the car I found the MAF Sensor being disconnected resolved it. Now I replaced the MAF filter block thing and replugged but found the same issue, if not slightly worse! So I found a forum and posted and got told to clean up the ICV and give the throttle body a clean. I did the ICV and got nowhere and now my car has developed a "sticky throttle". Any help would be massively appreciated!

20

Change your maf sensor

1 people found this helpful.
20

Hi Patrick change your fuel pump it will solve your issue

1 people found this helpful.
130

Hi Johhan I have a Corsa Bakkie 1.6 sports 1999 model I changed the petrol pump and a relay but still it doesn't push the petrol please help

2 people found this helpful.
20

good day. i have a problem with my 2001 opel corsa 1.4is the car shake when i driven, and the revs stay between 2-3 revs if i slow down to stop, and as i leave the clucth then the revs fine and as i want to change the gear then stay the revs between 2-3. I did replace al the parts. but still not right

2 people found this helpful.
10

Hi Johann, My name is wise, i have an opel corsa lite 3 doors 2008 model, while driving at 80km on Sunday, I felt a funny smell like fuses burning and the car start loosing power, presence of smoke coming through the radio side, I stopped for few minutes checked the engine and start again, the car drove but with less power with a loud sound, surprisingly inside on the gear lever area it was heating badly. If you can you please assist? Thanks,

1 people found this helpful.
20

Good day i have a corsa essentia 1.4 2009, the car makes a funny noise like a truck and when they checked it something wrong with the crank. I am not so technical about cars im really frustrated.

2 people found this helpful.

Hi Johann! Its Daniel here. I trust that you are well my man. Can you please assist me with my Corsa Essentia 2008 model. My car is using a Petrol Engine but it Roars like a DIESEL ONE. But in terms of performance, it performs soo soo well and is soo soo fast like a cheetah. So, my big question is, why is it roaring like a diesel Engine? Noisy engine. Thanks in advance sir!

10

Good morning @Johann please post your telephone number again. I am trying to reach you but keep getting voicemail.

1 people found this helpful.
10

Thers also some breather tht sits on the firewall check tht 2 it gves allot of shitt when its faulty

1 people found this helpful.
20

Which breather is it that you talking about, I have a feeling this could solve my problem, please be clear

30

Hi There is no current or power coming through to the injector plug on my opel corsa utility 2005 .What could the problem be as the car wont start? Please can you assist on some friendly advice? Regards Ashley

3 people found this helpful.
90

Hi Johan I have an opel corsa utility 1.7 dti 2007. The revs are always up it gives black smoke and heavy on fuel. It doesn't have power on an uphill or straight road. Only down hill it performs. Pls assist i have changed the glow plugs put on another turbo and it keeps on killing the alternators. I bought it October bought a new alternator in December. It died in April I have bought another one now again. Pls pls assist me. 0671887761

1 people found this helpful.

Hey its Eddie here, please i assist me with my Chevrolet Corsa 2011 model it doesn't supply petrol. It's sparking and all the fusses are perfect but it is not pumping petrol, thanks

100

Hi johann My name is Dineo and I drive a opel corsa GSI 1.6 2000 it is my life and it backfires and struggles for power when attempting to accelerate. I feel like I'm dying inside, it's my first car and I can't handle it not being able to fix it I'm too attached please help. I have sent it for machine diagnoses and there were no error codes. The mechanic checked the petrol filter and the timing but it's still doing the same thing. My number is 0658206217 dineom4@gmail.com

4 people found this helpful.
20

I have problem with my Corsa essential 1.4 it overheat and now is no longer starting it doesn't have power . please advice me 0609950266

2 people found this helpful.

Hi Everybody, I have a Corsa Gamma GSI 2004 LTD Edition. It stared cutting off a week ago, When idling it just goes off, When driving it gives a high rev then immediately turns off. What might be the problem?

210

Good day, All Gido I can't seem to view your answer on the Corsa Gamma GSI 2004 LTD Edition's problem, as I am experiencing the same thing with my Opel Corsa Lite Plus 2006 model. I've replaced my sensors etc., the guy that looked at my car send it to the auto electrician and they confirmed its my starter while someone already took my starter off and put it on another opel while I was there and it had no problem to start the other opel. The guy told me I must buy a new starter then I asked him can't it be send away to be fixed...then he told me I have a "reduced starter" so it cannot be fixed. My car has been looked at so many times but the same problem persist! I've even replaced the relay on my car as well. I need help please...my car has been standing for almost 5 month now :-(

2 people found this helpful.
10

Hi I drive a. 1998 Corsa B 1.6i whilst idling if I pull the 2nd plug wire motor makes no difference it overfuels wirh rough idle. Good compression on all 4 cylinders, new plugs, plug wires, new maf, map, tps and icv. Fault codes shows immobilizer function in ecu no or little signal. Lost my key a while ago so had the transponder removed and bypassed the ecu car starts first time

1 people found this helpful.

Hello. I am S.H Thebe Plse help I have an Opel Corsa 130i 1998, 3 days back it started leaking water heavily from under the engine. On inspection from under the car I discovered that the water was leaking from the engine- plug(welsh plug???). I couldn't buy the plug from my local Spares Shop since they required the size. I had to jack the car and get underneath again to try and measure the plug with a vernier caliper. I failed to get enough space which forced me to remove the Short Back water-pipe which connects the Black plastic pipe from the upper left side(non driver'side) to the back of the Water Pump. On removing the clamp I discovered that the hose and the clamp were just holding to a badly worn/rusted Waterpump pipe which crumbled when I tried to put the hose and the clamp back. My worse problem is that my pipefitting of the waterpump on the engine side has been completely corroded and worn-out: WHAT SHOULD I DO? Does replacing that waterpump pipefitting calls for taking out the whole engine? Plse HELP

My corsa lite don't enter gear 5 when the engine get hot, what could be the problem?

Hi guys my opel corsa utility doesn't burn fuel and plugs ..when i take out the plugs i found them black of smoke and it's eating too much fuel pls advise what can be the problem.

10

You must go and do a CO2 tune up. It sounds like your car over fuel.

1 people found this helpful.

Your Answer:

Corsa

Looking for a Used Corsa in your area?

CarGurus has thousands of nationwide listings and the tools to find you a great deal.

Postal Code:

Shortcuts

Opel Corsa Experts

  • #1
    Pardon Mupatsi
    Reputation
    1,940
  • #2
    Clifford Netshilonwe
    Reputation
    1,720
  • #3
    Rowefast
    Reputation
    1,180
View All

Find great deals from top-rated dealers

Search

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.