Trouble starting car, then dies.

Asked by May 04, 2019 at 12:19 AM about the 2005 Pontiac Aztek AWD

Question type: Maintenance & Repair

I have a 2005 Pontiac Aztek that has recently started giving me problems. A
few days ago, I noticed it was taking several seconds before it started and
even then you had to rev the engine a little to keep it running.
Today, the problem got worse. Now, it's even harder to start and when it
does, it only runs for a few seconds before dying.
This started happening a few days ago after I filled my tank up. Could it be
that I have bad gas, or is this due to something else, like a clogged fuel filter
or a pump going bad?

1 Answer

79,995

Most likely, this is a dirty idle air control valve or defective cold-start injector sticking at startup, and opening up using the accelerator makes up for this. This also affects how the engine behaves when coming to a stop. This could also involve the throttle position sensor and/or the fuel pressure regulator. You need a mechanic to diagnose and fix this.

Your Answer:

Shortcuts

Pontiac Aztek Experts

  • #1
    Thomas Killen
    Reputation
    350
  • #2
    ejhern
    Reputation
    300
  • #3
    Todd Smith
    Reputation
    160
View All

Find great deals from top-rated dealers

Search

Related Models For Sale

Used Pontiac Torrent
73 listings starting at $1,995
Used Toyota 4Runner
30 Great Deals out of 927 listings starting at $4,999
Used Toyota Tacoma
43 Great Deals out of 1,921 listings starting at $6,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.