Re- code 02 sensor dakota

Asked by Jan 01, 2017 at 02:00 PM

Question type: Maintenance & Repair

Thanks.
How do I go about testing of if its a wiring issue or
bad sensor or  intake issue..i was getting a odd
code in the background dodge enhanced mode of
p0100..maf sensor circuit (an I don't have a maf
sensor)..some background enhanced codes with
coolant temp  sensor circuit were found when
testing in run mode also..already replaced coolant
temp sensor...
But all that is on the check engine basic codes for
now is 02 sensor ..as mentioned.
I know they each effect the other also.temp
/map/02 sensors. NOTE I had just replaced the
exhaust manifold an gasket on passenger side
,had exhaust leak,an  new manifold had a LOT of
white like smoke burning off it from oil
preservative an I'm sure some of the pb Blaster
spray used on bolts in it was burning off too -'
2 or 3 runs an it was ok as to smoke..i reset
computer.

Can this  "heavy chemical burn off "ruin the 02
sensor (there after converter)?

1 Answer

105,375

Usually a chemical burn off will ruin the upstream O2 sensor not the downstream. If your getting a downstream code then pull the sensor out and check it for physical damage, if the ports are plugged clean it and reinstall, if you scanner is capable of "love data" then enter that screen and watch the O2 readings after they reach operational temps the downstream should have very limited switching. You can read more here: http://www.autotap.com/techlibrary/catalytic_converters_and_o2_ sensors.asp

Your Answer

Shortcuts

Maintenance & Repair Experts

  • #1
    Tom Demyan
    Reputation
    186,170
  • #2
    dandyoun
    Reputation
    97,270
  • #3
    tennisshoes
    Reputation
    82,470
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.