Went from bad alternator to bad miss now won't start at all

Asked by Dec 30, 2016 at 11:23 AM about the 2000 Oldsmobile Alero GL Coupe

Question type: Maintenance & Repair

2000 Oldsmobile alero bad alternator to
bad miss and now won't start at all. At first
the car needed a jump so bought a new
battery and put it in and battery light was
still on so was driving to have alternator
tested and it started missing real bad so I
brought it home and replaced spark plugs
and oil sending unit because oil was
dripping on spark plugs and checked out
coil pack housing for cracks  and put it
back on and now it won't start at all and
sounds like the starter is out. Does anyone
know what could be causing all this
trouble?

1 Answer

26,615

Check all your connections again, if battery terminals and connections are good try a voltage drop test to the starter. Can also check main fuse and starter relay.

Your Answer

Oldsmobile Alero Experts

  • #1
    sun4shine2006
    Reputation
    600
  • #2
    Chris Kelso
    Reputation
    240
  • #3
    Rowefast
    Reputation
    210
View All

Related Models For Sale

Used Nissan Altima
73 Great Deals out of 1,361 listings starting at $2,500
Used Chevrolet Impala
122 Great Deals out of 1,052 listings starting at $1,500
Used Honda Accord
83 Great Deals out of 1,054 listings starting at $1,200
Used Pontiac Grand Prix
5 Great Deals out of 84 listings starting at $1,800
Used Ford Taurus
15 Great Deals out of 322 listings starting at $4,900
Used Chevrolet Malibu
82 Great Deals out of 2,215 listings starting at $2,994
Used Toyota Camry
56 Great Deals out of 1,964 listings starting at $750
Used Honda Civic
297 Great Deals out of 3,484 listings starting at $995
Used Hyundai Elantra
189 Great Deals out of 3,390 listings starting at $2,295

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.