Went from bad alternator to bad miss now won't start at all

Asked by Dec 30, 2016 at 11:23 AM about the 2000 Oldsmobile Alero GL Coupe

Question type: Maintenance & Repair

2000 Oldsmobile alero bad alternator to
bad miss and now won't start at all. At first
the car needed a jump so bought a new
battery and put it in and battery light was
still on so was driving to have alternator
tested and it started missing real bad so I
brought it home and replaced spark plugs
and oil sending unit because oil was
dripping on spark plugs and checked out
coil pack housing for cracks  and put it
back on and now it won't start at all and
sounds like the starter is out. Does anyone
know what could be causing all this
trouble?

1 Answer

30,985

Check all your connections again, if battery terminals and connections are good try a voltage drop test to the starter. Can also check main fuse and starter relay.

Your Answer

Oldsmobile Alero Experts

  • #1
    sun4shine2006
    Reputation
    610
  • #2
    Chris Kelso
    Reputation
    260
  • #3
    Nir Eliyaho
    Reputation
    210
View All

Related Models For Sale

Used Chevrolet Malibu
96 Great Deals out of 1,755 listings starting at $888
Used Honda Civic
267 Great Deals out of 4,266 listings starting at $1,995
Used Pontiac Grand Am
30 listings
Used Volkswagen Beetle
32 Great Deals out of 368 listings starting at $2,697
Used Nissan Sentra
195 Great Deals out of 1,826 listings starting at $2,200
Used Chevrolet Camaro
928 listings starting at $12,498
Used Buick Regal
4 Great Deals out of 233 listings starting at $7,495

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.