Battery problems

Asked by Jan 04, 2017 at 06:38 PM about the 2003 Oldsmobile Alero GL Coupe

Question type: Maintenance & Repair

Cold weather has made it difficult to start my car.
Twice it has been dead and it started right away
with a jump. Today when it wouldn't start I popped
the hood and shook the battery a little and it
started. All connections seemed ok So I'm
wondering what else may cause this

1 Answer

73,035

More than likely the battery needs replacing. Also the charging system needs to be checked out. If you had a digital multi-meter you could check to see if it is putting out 14.5V at the battery when the car is running.

1 of 1 people found this helpful.

Your Answer

Oldsmobile Alero Experts

  • #1
    sun4shine2006
    Reputation
    590
  • #2
    Chris Kelso
    Reputation
    230
  • #3
    Nir Eliyaho
    Reputation
    200
View All

Related Models For Sale

Used Pontiac Grand Am
32 listings starting at $3,960
Used Chevrolet Malibu
110 Great Deals out of 2,275 listings starting at $2,500
Used Chevrolet Impala
58 Great Deals out of 930 listings starting at $1,900
Used Nissan Altima
65 Great Deals out of 1,275 listings starting at $2,750
Used Toyota Camry
43 Great Deals out of 1,599 listings starting at $1,700
Used Ford Taurus
23 Great Deals out of 309 listings starting at $4,900
Used Nissan Maxima
29 Great Deals out of 332 listings starting at $3,976
Used Ford F-150
428 Great Deals out of 9,065 listings starting at $922
Used Honda Accord
67 Great Deals out of 1,127 listings starting at $748
Used Toyota Corolla
153 Great Deals out of 3,430 listings starting at $2,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.