Battery problems

Asked by Jan 04, 2017 at 06:38 PM about the 2003 Oldsmobile Alero GL Coupe

Question type: Maintenance & Repair

Cold weather has made it difficult to start my car.
Twice it has been dead and it started right away
with a jump. Today when it wouldn't start I popped
the hood and shook the battery a little and it
started. All connections seemed ok So I'm
wondering what else may cause this

1 Answer

75,605

More than likely the battery needs replacing. Also the charging system needs to be checked out. If you had a digital multi-meter you could check to see if it is putting out 14.5V at the battery when the car is running.

1 of 1 people found this helpful.

Your Answer

Oldsmobile Alero Experts

  • #1
    sun4shine2006
    Reputation
    610
  • #2
    Chris Kelso
    Reputation
    260
  • #3
    Rowefast
    Reputation
    210
View All

Related Models For Sale

Used Ford Mustang
14 Great Deals out of 1,153 listings starting at $4,500
Used Chevrolet Malibu
110 Great Deals out of 2,039 listings starting at $3,485
Used Chevrolet Impala
113 Great Deals out of 1,113 listings starting at $996
Used Nissan Maxima
39 Great Deals out of 398 listings starting at $2,985
Used Toyota Camry
109 Great Deals out of 2,546 listings starting at $2,000
Used Pontiac Grand Prix
6 Great Deals out of 72 listings starting at $1,600
Used Chevrolet Camaro
917 listings starting at $12,000
Used Jeep Grand Cherokee
121 Great Deals out of 3,954 listings starting at $2,699

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.