Starts and dies shortly with sputter

10

Asked by Jun 24, 2017 at 12:26 PM about the 1997 Mercury Villager 3 Dr LS Passenger Van

Question type: Maintenance & Repair

I have had it to do this 3 times now! I have replaced
the battery, fuel filter, and the very expressive maf
sensor and still no luck.
Runs for about a half minute and stalls down and
sputters.
I can restart and does the same thing!
Have had it in the shop second time this happened
and after a day and a half they charged me and
couldn't find a problem.
I am very frustrated this is my only transportation
and I am failing to be able to get back and forth to
work!

1 Answer

10

not sure how to add a comment/follow-up. but, I just spent $172 for a MAF sensor and tht didn't do a thing for me!!

1 of 1 people found this helpful.

Your Answer

Shortcuts

Mercury Villager Experts

  • #1
    Tom Demyan
    Reputation
    280
  • #2
    tenspeed
    Reputation
    170
  • #3
    dandyoun
    Reputation
    150
View All

Related Models For Sale

Used Nissan Quest
71 listings starting at $2,500
Used Toyota Sienna
20 Great Deals out of 1,165 listings starting at $2,495
Used Honda Odyssey
31 Great Deals out of 946 listings starting at $1,499
Used Ford Explorer
40 Great Deals out of 1,504 listings starting at $1,799
Used Dodge Grand Caravan
320 Great Deals out of 14,969 listings starting at $2,000
Used Toyota 4Runner
3 Great Deals out of 557 listings starting at $2,152
Used Porsche 911
5 Great Deals out of 197 listings starting at $19,900
Used Audi A4
39 Great Deals out of 609 listings starting at $2,880
Used Toyota Camry
104 Great Deals out of 2,317 listings starting at $2,495

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.