Starts and dies shortly with sputter

Asked by Jun 24, 2017 at 12:26 PM about the 1997 Mercury Villager 3 Dr LS Passenger Van

Question type: Maintenance & Repair

I have had it to do this 3 times now! I have replaced
the battery, fuel filter, and the very expressive maf
sensor and still no luck.
Runs for about a half minute and stalls down and
sputters.
I can restart and does the same thing!
Have had it in the shop second time this happened
and after a day and a half they charged me and
couldn't find a problem.
I am very frustrated this is my only transportation
and I am failing to be able to get back and forth to
work!

1 Answer

not sure how to add a comment/follow-up. but, I just spent $172 for a MAF sensor and tht didn't do a thing for me!!

Your Answer

Shortcuts

Mercury Villager Experts

  • #1
    Tom Demyan
    Reputation
    270
  • #2
    tenspeed
    Reputation
    170
  • #3
    dandyoun
    Reputation
    150
View All

Related Models For Sale

Used Nissan Quest
65 listings starting at $2,995
Used Toyota Sienna
15 Great Deals out of 1,098 listings starting at $2,995
Used Buick LeSabre
13 listings starting at $1,400
Used Toyota RAV4
53 Great Deals out of 3,192 listings starting at $2,495
Used Honda Odyssey
11 Great Deals out of 949 listings starting at $2,999
Used Chevrolet Astro
10 listings starting at $4,500
Used Ford Mustang
9 Great Deals out of 1,128 listings starting at $1,250
Used Subaru Forester
56 Great Deals out of 983 listings starting at $1,670

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.