I have a 1999 Mercury Villager that keeps shutting off the battery light stays on along with the brake light but it is a brand new battery. I also have a hole in the tail pipe and it aputters and the the car shuts off. I have changed the fuel filter and the starter

115

Asked by Mar 15, 2014 at 11:18 AM about the 1999 Mercury Villager 4 Dr Estate Passenger Van

Question type: Maintenance & Repair

I have a 1999 Mercury Villager that keeps shutting off the battery light stays on along with the brake light but it is a brand new battery. I also have a hole in the tail pipe and it aputters and the the car shuts off. I have changed the fuel filter and the starter. The gas get in the car what is causing my battery light and brake light to come on then the car shuts off after running for 10 minutes

2 Answers

115

I found out the answer I think the alternator belt is missing.

2 people found this helpful.
10

Really f****** alternator come on

1 people found this helpful.

Your Answer:

Shortcuts

Mercury Villager Experts

  • #1
    tenspeed
    Reputation
    180
  • #2
    Trippmeister
    Reputation
    170
  • #3
    dandyoun
    Reputation
    160
View All

Find great deals from top-rated dealersTM

Search

Related Models For Sale

Used Nissan Quest
54 listings starting at $6,650
Used Chrysler Town & Country
11 Great Deals out of 322 listings starting at $3,700
Used Ford Ranger
5 Great Deals out of 1,097 listings starting at $3,950
Used Toyota Sienna
34 Great Deals out of 1,047 listings starting at $2,600

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.