replaced the water pump, thermostat and radiator care still run hot while setting idle

Asked by Aug 13, 2017 at 12:48 PM about the 2002 Mercury Sable LS Premium Sedan FWD

Question type: Maintenance & Repair

2 Answers

76,265

Have you checked the radiator fan,s and made sure they are working?

3,880

Yep fans also are you sure system is completely full and no air exists? Testing these fans are easy, 2 wires from fan to battery.

Your Answer:

Shortcuts

Mercury Sable Experts

  • #1
    JP1956
    Reputation
    830
  • #2
    Tom Demyan
    Reputation
    720
  • #3
    Guy Outland
    Reputation
    410
View All

Related Models For Sale

Used Ford Taurus
19 Great Deals out of 382 listings starting at $4,995
Used Honda Accord
33 Great Deals out of 1,673 listings starting at $1,800
Used Chevrolet Impala
18 Great Deals out of 1,010 listings starting at $2,994
Used Toyota Camry
26 Great Deals out of 2,104 listings starting at $2,995
Used Toyota Corolla
119 Great Deals out of 4,274 listings starting at $2,300
Used Chevrolet Malibu
46 Great Deals out of 1,985 listings starting at $2,390
Used Ford F-150
119 Great Deals out of 11,225 listings starting at $369
Used Ford Explorer
22 Great Deals out of 1,812 listings starting at $4,490
Used Nissan Altima
38 Great Deals out of 1,230 listings starting at $2,995
Used Buick LeSabre
6 listings

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.