2000 Mazda Protege no electrical power

Asked by Jun 25, 2017 at 12:33 PM about the 2000 Mazda Protege ES

Question type: Maintenance & Repair

My 2000 Mazda Protege has no power at all. When  
I disconnect the ground on the battery and
reconnect, everything on the dash comes back on,
but when I go to start it, it clicks, and everything
shuts completely off again. It looks like there is
already a new alternator on it, and I don't know how
old the battery is. I've had it for 2 weeks. Last time
it did it I just disconnected the battery and charged
it out of car and it worked for 2 weeks. Now it's
died again and it won't hold a charge or something.
I think its the alternator diode causing too much
parasitic draw, but its too weird to be that simple.
Just need some other opinions.

No answers yet

Your Answer

Mazda Protege Experts

  • #1
    James Kithuka
    Reputation
    280
  • #2
    dandyoun
    Reputation
    220
  • #3
    Js08016
    Reputation
    160
View All

Related Models For Sale

Used Honda Civic
323 Great Deals out of 4,171 listings starting at $1,494
Used Honda Accord
77 Great Deals out of 1,112 listings starting at $748
Used Mazda MX-5 Miata
211 listings starting at $4,995
Used Nissan Altima
70 Great Deals out of 1,277 listings starting at $2,750
Used Toyota Corolla
160 Great Deals out of 3,427 listings starting at $2,500
Used Nissan Sentra
159 Great Deals out of 1,753 listings starting at $1,987
Used Ford Mustang
9 Great Deals out of 1,179 listings starting at $2,995
Used Ford Focus
130 Great Deals out of 2,583 listings starting at $750
Used Subaru Impreza
51 Great Deals out of 890 listings starting at $2,490

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.