When I try to get in the gas I loose power

Asked by May 23, 2017 at 07:54 PM about the 1996 Chevrolet C/K 1500 Cheyenne Extended Cab LB 4WD

Question type: Maintenance & Repair

I have a 1996 chevy 1500 with the 5.7 and the
4l60e transmission just got it rebuilt and now when
the truck is running at an idle in park and Rev it up
everything sounds good but when I start driving
and try to take off fast it seems like it looses power
, but if you give it gas slowly it will go fine any ideas

1 Answer

76,235

Was any part of the fuel delivery system changed? May have a plugged fuel filter, or the fuel pump is weak, and lastly a problem with the spider injection assembly. Check the fuel pressure with a fuel pressure gauge at the Schrader Valve, it should be 56 to 63 lbs. and rev. up the engine to see if it holds the proper fuel pressure.

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    3,820
  • #2
    John Saffrahn
    Reputation
    2,650
  • #3
    Rowefast
    Reputation
    2,210
View All

Related Models For Sale

Used GMC Sierra 1500
248 Great Deals out of 10,472 listings starting at $399
Used Ford F-150
639 Great Deals out of 10,343 listings starting at $2,995
Used Dodge Ram 1500
58 Great Deals out of 497 listings starting at $2,500
Used Chevrolet Tahoe
4 Great Deals out of 737 listings starting at $3,995
Used Chevrolet Camaro
922 listings starting at $13,495
Used Chevrolet S-10
12 listings starting at $1,750
Used Toyota Tacoma
46 Great Deals out of 1,104 listings starting at $7,950

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.