1976 Chevy truck electrical system question

Asked by Jun 28, 2017 at 11:07 PM about the 1988 Chevrolet C/K 2500 Cheyenne Standard Cab LB

Question type: Maintenance & Repair

I have a 1976 C20 that I am trying to get running. The mechanicals are in
line and the engine turns freely. I have checked the two fusible links that I
know of on the firewall and by the starter. I opened and cleaned the block on
the firewall by the brake booster. I have no power at all, nothing, no lights no
ignition lights or anything else in the cab.  I have checked the ignition switch
on the column with my multimeter and am getting current across the different
connections. Just trying to get current into the cab. One thing I think is
suspect but cannot confirm is the two terminal block at the center of the
firewall. A 10 gauge fused wire runs from the block into the cab on the
passenger side. See pics. Any help would be much appreciated.

No answers yet

Your Answer

Chevrolet C/K 2500 Experts

  • #1
    Rowefast
    Reputation
    290
  • #2
    COMETGUY61
    Reputation
    190
  • #3
    Andrew Olsen
    Reputation
    140
View All

Related Models For Sale

Used GMC Sierra 2500
4 listings starting at $10,553
Used Ford F-250
5 listings
Used Ford F-150
459 Great Deals out of 9,063 listings starting at $922
Used GMC Sierra 1500
224 Great Deals out of 10,442 listings starting at $2,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.