Why does 2008 Ford Crown Vic P71 instruments go out and on while car stopped or moving?

80

Asked by bigmilky1 Dec 10, 2014 at 09:07 PM about the 2008 Ford Crown Victoria Police Interceptor

Question type: General

I have an 08 Ford Crown Vic P71.  Instruments on dashboard go out for 1 sec to 2 secs then come back on.  Sometimes it will go out for 10+ seconds before I tap the dashboard.  They come back on.  The radio, headlights, blower, etc. all continue to work.  Problem located in instrument area only.  It has been taken to two different car shops.  One shop said no codes found.  Didn't know what was causing it.  It was going to cost more hours = $ to find the root of the problem. Second shop charged two hours labor and provided no answers.  What is going on?  Please help & thanks!

13 Answers

72,195

I've bought many a used P71 at auction, and had to deal with PDs ripping out their electronics and leaving a mess. I recommend buying a decent digital volt ohm meter and start checking for continuity at the connectors to the instrument panel. You might have a faulty ground in the vicinity of the fuse block, as that is where the PDs start hacking away at the wires they installed for their lights/sirens. The forums at Crownvic.net have good write-ups of troubleshooting electronic gremlins in P71s.

12 people found this helpful.
80

Thanks for the fast response. Do you think it could be the instrument cluster at all? The gentleman who I purchased this car from told me today it could be an instrument cluster. He said usually it is the odometer that goes out but in my case, the entire panel goes down. Like you, he has purchased many police interceptors at auction & sells them to taxi companies or keeps them for himself for private sale. Thanks again.

6 people found this helpful.
80

Also, do you think it is safe to drive with this issue occurring? It has been occurring off-and-on for two weeks now, and knock on wood, traveling has been fine. Thanks.

2 people found this helpful.
160

Common problem with these instrument clusters. They can be repaired for both the intermittent gauges and odometer dark or very dim. Google mrwhizard for more info.

3 people found this helpful.
60

I think it has to do with the wiring harness that plugs into the instrument cluster. ( for me anyway) I took my dash apart, and found that if I push down hard on the plug for the instrument cluster the cluster starts to work again and comes back on . If i wiggle the wires a little the instrument cluster stops working. I now think I have to learn how to repair the plug and wires that go into the cluster. It might just need some electric parts cleaner. If I get it fixed I will try and come back and post the fix.

2 people found this helpful.
60

I got my instrument cluster fixed everything is working fine. The problem was the cluster itself I took a chance and paid $150 to auto tech rescue in Loma Linda MO. They repaired my cluster I reinstalled it and has been working fine for a week now . one tip once you reinstall the cluster don't pull it it fully back together just install the cluster without the glass and don't reinstall the dashboard. Run like that for a few days because you might have to reset to speedometer needle. The needle pulls right out and you can reset it and push it back in. Good luck

4 people found this helpful.
20

I started having the dash problem after I began parking on a hill and using the e-brake. When the gauges stop working, sometimes if I push the ebrake all the way down and then release, it kicks back on....

2 people found this helpful.
30

Sent mine out plugged it in and the odometer did not pop on the rest of the cluster was working. Then it kicked on for a min then back off.. any ideas?

3 people found this helpful.
30

u have a loose wire or a fuse,tap the dash at various places to try to make it flicker the lights,also could be light switch,do head lights do the same way? wiggle wires around fuse box and light switch,maybe E brake is hitting wires when used? all these are guesses! good luck hunting,but it's a loose connection,start on one side of the dash and go to the other it will show up! FRED

3 people found this helpful.
30

Ok, my 07 crown Vic instrument cluster would flicker on and off constantly. Located the problem it was a defective drivers side windows switch. A short in the lighting circuit. Remember aa lot of the police operators would drive with the window open even if it was raining . Just a lucky find -no issues since replacing the window switch.

3 people found this helpful.
30

Odometer display failure and full power loss is very common for 2006-2011 Crown Victoria, Grand Marquis and Town Cars. We, at Automotive Circuit Solutions, have repaired hundreds of these clusters with these issues. If you'd like to send your cluster to us you can find all the details on our website here. https://www.automotivecircuitsolutions.com/collections/ford/products/06-11-ford-crown- victoria-gauge-cluster-mail-in-repair-service-24-hour-turnaround

3 people found this helpful.
40

Lightly kick or tap the panel to the left of your brake pedal. If your display comes back on, there is a loose connector there. Before you go into your dash try removing that panel and checking that connection.

4 people found this helpful.

Your Answer:

Crown Victoria

Looking for a Used Crown Victoria in your area?

CarGurus has 15 nationwide Crown Victoria listings and the tools to find you a great deal.

Postal Code:

Ford Crown Victoria Experts

  • #1
    Tracy Hooks
    Reputation
    3,210
  • #2
    Bob Beaman
    Reputation
    1,800
  • #3
    G A Arne
    Reputation
    1,410
View All

Find great deals from top-rated dealers

Search

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.