302 only runs full throttle

Asked by Jun 28, 2017 at 10:44 PM about the 1984 Ford E-150 Club Wagon

Question type: Maintenance & Repair

I'm a nomad living in my 1984 E150 and I'm in
Colorado, I was in Woodland Park for a couple
days, I stopped at a Safeway to sleep for the night
and when I woke up my van was off, I thought I had
run out of gas but there was plenty left in the
reserve tank and main tank. So I tried to start it
again, put the peddle to the floor and it started but
it would die the second I let off the gas. It runs very
very low RPM. I replaced the spark plugs, plug
wires, cap and rotor, and still the issue persists.
But the strange thing is on the right side of the
motor there's a ton of gunk on the pistons, enough
that it's very noticeable through the plug hole. And
after replacing the plugs and trying to run it for a
few minutes at a time the plugs were black again
and one has oil on it.
Is my carburetor just running way too rich? Or is it
something serious like a messed up valve, or a
blown head gasket, damaged piston rings etc?

No answers yet

Your Answer

Ford E-150 Experts

  • #1
    Tracy Hooks
    Reputation
    510
  • #2
    kbro
    Reputation
    440
  • #3
    tennisshoes
    Reputation
    390
View All

Related Models For Sale

Used Ford F-150
447 Great Deals out of 9,147 listings starting at $3,000
Used Ford F-250
4 listings
Used Ford F-100
1 listing

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.