2003 Dodge Stratus 2.4L high idle

20

Asked by Mike_P May 19, 2013 at 09:53 AM about the 2003 Dodge Stratus SE Sedan FWD

Question type: Maintenance & Repair

I have an '03 Dodge Stratus with a 2.4L that was running a little rough with only 47k miles
on it. I changed the oil & filter, replaced the spark plugs with NGK plugs and replaced the
oil filter. I started it up and now it's idling about 3,000 RPMs and will not kick down at all. I
pulled the air filter back out and checked all the connections and that seems okay, but
the idle will not kick down. Does anyone have any ideas?

16 Answers

20

Edit: Don't know how to edit my post. I replaced the oil & filter, spark plugs and air filter. I realized I posted oil filter twice. Sorry for the confusion.

Sorry, I am coming up empty on what the problem with your car is. Chances are somebody else will have some ides, But to edit you post, highlight it, copy and paste it in a new "Your Answer" box, then you can edit as necessary, re post it, then delete the old one by clicking on the little triangle arrow in the upper right of the box with the answer in it, click 'delete post', you will get an "are you sure.." click 'yes" and it will be gone

1 people found this helpful.
163,495

Double check that the air filter box is completely closed. Check for any vacuum lines that might have come undone during the tune up. Check maf sensor is plugged in securely. Also is your cel on?

20

I disconnected the sensor on the hose for the air filter when I changed it. I read on another post that it might be the problem. The post said to disconnect it and if your idle drops that's the problem. So to answer the question about the CEL, the light was not on until I disconnected that sensor and also the idle did not drop when I disconnected it either. So now I have the high idle still and now the CEL is on from me trying that test I read on another post.

163,495

Un hook your battery for about ten minutes and that should reset your cel. Was there a high idle before you serviced it or just after? If only after I still thinking a vacuum issue.

20

Had a rough idle before the tune up. The high idle only started after tune up. I checked everything I touched and I can't find anything wrong. Tune up if fairly easy on this car and doesn't require touching much that you are not actually working on like some vehicles. I am thinking I might of did something or touched something that might of been causing the rough idle I originally started with.

1 people found this helpful.
20

That looks different. My throttle body is in front. The PCV is on the drivers side of the cover, the spark plugs are right on top thru the valve cover towards the rear of the engine, the air filter is where the battery would typically be located and let's not forget that the battery is actually in the front bumper below the drivers side headlight on this car.

163,495

Oh ok. Check any electrical connections that are anywhere near where you were working. Don't unhook them just wiggle and push in just incase one is loose. Specially around the throttle body.

20

I only disconnected 1 electrical connection replacing the air filter. I have already triple checked that connection and I've already been wiggling all the other connections and checking the vacuum lines although I only disconnected 2 to change the air filter. I am thinking I aggreviated the real problem that was causing the rough idle and now I have this high idle as a result. But in any case, it started raining here about an hour ago, so I am done working on it today.

20

Thanks for your help. If I figure it out, I will post it.

10

Hi, I just changed the oil and filter to my dodge stratus 2003, and I had the same problem that you had with your car. I was wondering if you could fixed the problem. Can you help me ?

1 people found this helpful.
20

When I changed the air filter a piece of plastic from the sensor broke off and fell into the throttle body and got stuck in the AIS motor. Pulled the throttle body apart and removed the broken piece and had to replace the sensor that was in the air cleaner hose which is where the plastic piece came from. Hope this helps.

1 people found this helpful.

What did u gap your plugs at? The book and the label under hood says .050 but most forums(including auto zone) suggest .040 which has worked great for me:-) I've changed out the coil, boots, IAC, camshaft sensor, map sensor, pcv valve, plugs, air filter and the grounding strap and clip behind the head only for it to randomly go into limp mode on me with about a month in between episodes....grrrr..

1 people found this helpful.

You could also try switching out your throttle position sensor

Coukd be vacuum leake dirty iac or bad throttle position sensor. Dirty throttle body.

Your Answer:

Stratus

Looking for a Used Stratus in your area?

CarGurus has 1 nationwide Stratus listings and the tools to find you a great deal.

Postal Code:

Dodge Stratus Experts

  • #1
    Chris Daigle
    Reputation
    790
  • #2
    Reelin68
    Reputation
    710
  • #3
    hatterha
    Reputation
    650
View All

Find great deals from top-rated dealers

Search

Related Models For Sale

Used Honda Accord
55 Great Deals out of 1,855 listings starting at $1,970
Used Dodge Durango
44 Great Deals out of 905 listings starting at $5,995
Used Dodge Viper
37 listings starting at $32,115
Used Chrysler Sebring
115 listings starting at $3,450
Used Chevrolet Impala
16 Great Deals out of 895 listings starting at $2,495
Used Dodge RAM 1500
15 Great Deals out of 311 listings starting at $3,500
Used Chevrolet Blazer
5 Great Deals out of 1,187 listings starting at $4,790
Used Dodge Grand Caravan
137 Great Deals out of 10,335 listings starting at $2,600
Used Dodge Dakota
94 listings starting at $4,494

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.