After changing timing belt and water pump why does my engine not wanna start

Asked by Mar 26, 2017 at 11:45 PM about the 2006 Dodge Magnum SXT AWD

Question type: Maintenance & Repair

1 Answer

330

If your car are working before you did the timing belt and water pump but now doesn’t run after, I would say that the timing is off. Make double and triple to make sure that you’re using the correct marks on the camshafts and crankshaft, and make sure that the belt is properly tensioned.

Your Answer:

Dodge Magnum Experts

  • #1
    Norm Davis
    Reputation
    410
  • #2
    Miguel Carrasco
    Reputation
    380
  • #3
    XS22L9R
    Reputation
    280
View All

Related Models For Sale

Used Dodge Charger
45 Great Deals out of 925 listings starting at $3,500
Used Chrysler 300
32 Great Deals out of 1,025 listings starting at $3,500
Used Ford Mustang
34 Great Deals out of 1,238 listings starting at $4,685
Used Jeep Grand Cherokee
59 Great Deals out of 5,326 listings starting at $2,994
Used Dodge Durango
24 Great Deals out of 1,106 listings starting at $2,500
Used Chevrolet Impala
22 Great Deals out of 879 listings starting at $2,894
Used Dodge Ram 1500
35 Great Deals out of 521 listings starting at $2,500
Used Chevrolet Tahoe
11 Great Deals out of 793 listings starting at $5,900
Used Ford F-150
132 Great Deals out of 11,559 listings starting at $3,900
Used Chevrolet Corvette
9 Great Deals out of 518 listings starting at $10,700
Used Pontiac GTO
5 listings

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.