Car cranks but wont start

Asked by Feb 18, 2017 at 12:44 PM about the 2006 Dodge Charger RT

Question type: Maintenance & Repair

I have a 2006 dodge charger 2.7 and it cranks but wont
start. Codes that come up are crank sensor n for throttle
pedal n sensor. I already replaced crank sensor. I changed
spark plugs n they were bad,its been year since last
changed. 130,o00 miles. I cleaned throttle , i started car but
cranked no start. I sprayed sum starter fluid on throttle cam
n cranked car,looked like it was bout to start but i smelled
smoked coming out of throttle n i turned off key. Motor
never turned on ,almost did but before it could i turned it
off. Could i have messed up motor ? My battery was
weak,getting it charged right now but im worried that i
messed up motor or something. Any information,hopefullt
good news ,woukd be appreciated. I called random shops n
mechanics said i probably didnt hurt anything.

14 Answers

98,445

If the computer is seeing an throttle pedal sensor problem it may shut off the injectors, and that would explain the almost start with the starter fluid, and some smoke would be noticeable just due to valve overlap and the low flash point of the starter fluid, and no I don't think you damaged the engine. So replace the pedal sensor and follow the directions to the letter, and if you battery fails the test then replace it. However I am worried that you have removed the battery on an 06 vehicle, especially a Chrysler product, there is a tool that needs to be installed in the OBD 2 port that keeps the BCM's memory alive, without it that computer looses all the factory presets resulting in some if not all of your accessories to stop operating, if that has happened then the only place that can undo this is the dealer, they will have to reflash the system to bring everything back. I my area it runs a hundred bucks. So here's hoping it all works when you reinstall the battery.

It started n is running well, when i was trying to start car , battery sounded like it was dead, barely was cranking, i couldnt hear fuel pump turning on, but after pumping gas pedal,car started n is running well, by the way it runs ,you would think car is perfect but at around 11pm it will start again,crank but not start, during the day time i can turn off car n it will start, no codes so far, only hv the lighting bolt light on.

98,445

Then your having voltage problems, unstable voltage can cuse all kinds of driveabality problems, have the charging system checked, as this is a computer controlled charging system voltages need to be stable.

I replaced the crankshaft sensor ,had code for it car would turn off n hard to turn on. Replaced new sensor n car started easily n was running perfectly but then again started turning off by itself n running hard n crankshaft sensor code came back again. Not sure why it would code would come back again when i just replaced sensor. Any ideas? Thank you very much for any assistance.

98,445

Chrysler products are very picky about their sensors, if it was an aftermarket crank sensor it most likely isn't working right for the make of the vehicle. I had the similar with a Jeep, used aftermarket crank sensor and about every third crank it would act like the battery was weak but it wasn't, finally put the crank sensor on a lab scope and found it was sending erratic pulses, put on another one and the same thing, finally went with a OEM sensor and no more erratic signal and no more problems.

The two i put are gtd for life from oreilys. Do u think it could be the harnes or wire thats cut thats causing this?

98,445

Possibly, is there evidence that there might be such a problem? Most common wire breakage points is right at the sensor connector. And it was O'Reilies sensors that gave me the bad signals.

I normally get my parts at autozone,not sure if its dift. The clips on the connector broke, inside the connector is fine but the both clips broke off, i was thinking of putting black tape to secure connection. Awhile ago i took off fuses #11 n #15 n put back 9n n car started goid n was runni g on park for good 15 minutes n then turn off by itself...

98,445

A lab scope would be able to show the signal when it is in failure, but 15 minutes is just the right amount of time for the sensor to warm up from engine heat an go open, so no signal at all.

I applied for a loan from my 401k to see if i can fix it at a shop,i already spent over $500 for new key n reprogrammed, changing spark plugs,engine coolant sensor, was hoping to get blessed n be something small that i could fix , at times i thought fuel pump was going out but honestly now im not sure, hopibg its something small or semi small not a big cost job.

98,445

Nothing is small any more, it now costs 150 bucks just to have the system checked at a dealership, and the cost of good testing equipment just keeps climbing.

The giy i bought car from didnt put a new fuel pump,its a savage fuel pump smh im going to put a new one on friday but car again was crankibg but not start ,i was checking fuel pump relay n notice a small metal screw was underneath fuel pump relay, unless it fell from somewhere else n when i pulled relay it was there but i could bet it was underneath fuel pump relay, i asked guy i bought car from n he said he didnt put no screw there, is there a purpose to do that?

Update* turns out it was the crankshaft sensor, as soon as i put new sensor ,car cranked easily n ran very good for 15 minutes then turned off by itself n hard to turn on. Waited few minutes,cranked n started easily, has not turned off n starts very easily. Its been 3 days n so far working very well. Idk if the computer takes a few minutes to set everything cus after the 15 minutes its been working very well. Thanks

98,445

Right, it can take 20 minutes drive time to get the ECM to reset its parameters when you replace a sensor. So clear the codes and drive as you normally would for 20 minutes and if everything it right then there won't be any check engine light.

Your Answer

Charger

Looking for a Used Charger in your area?

CarGurus has 818 nationwide Charger listings starting at $1,999.

Postal Code:

Dodge Charger Experts

  • #1
    Supanovah
    Reputation
    2,220
  • #2
    Willie Francis
    Reputation
    2,130
  • #3
    Tom Demyan
    Reputation
    840
View All

Related Models For Sale

Used Ford Mustang
9 Great Deals out of 1,191 listings starting at $2,995
Used Chrysler 300
95 Great Deals out of 1,032 listings starting at $1,995
Used Chevrolet Impala
61 Great Deals out of 938 listings starting at $1,900
Used Jeep Grand Cherokee
108 Great Deals out of 2,738 listings starting at $1,871
Used Chevrolet Silverado 1500
162 Great Deals out of 10,662 listings starting at $100
Used Chevrolet Corvette
710 listings starting at $4,450
Used Honda Accord
62 Great Deals out of 1,114 listings starting at $748
Used Ford F-150
455 Great Deals out of 9,064 listings starting at $922
Used Dodge Durango
62 Great Deals out of 1,013 listings starting at $2,998
Used Nissan Maxima
29 Great Deals out of 324 listings starting at $3,976
Used Chevrolet Tahoe
6 Great Deals out of 632 listings starting at $6,871
Used BMW 3 Series
152 Great Deals out of 1,908 listings starting at $2,300
Used Dodge Ram 1500
62 Great Deals out of 527 listings starting at $2,995

Used Cars For Sale

2017 Dodge Charger For Sale
154 listings starting at $32,991
2016 Dodge Charger For Sale
46 Great Deals out of 305 listings starting at $21,995
2015 Dodge Charger For Sale
9 Great Deals out of 69 listings starting at $18,688
2014 Dodge Charger For Sale
3 Great Deals out of 50 listings starting at $14,600
2013 Dodge Charger For Sale
3 Great Deals out of 30 listings starting at $10,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.