2010 Chevy Aveo Lt engine runs but no power

Asked by Jul 12, 2017 at 10:17 PM about the 2010 Chevrolet Aveo LT

Question type: Maintenance & Repair

So my 2010 chevy Aveo engine runs but when I put
into drive or reverse there's no power when trying to  
accelerate pushing the gas pedal all the way
down,what's the reason why my car doesn't wanna
gas

No answers yet

Your Answer

Chevrolet Aveo Experts

  • #1
    Tom Demyan
    Reputation
    330
  • #2
    martco
    Reputation
    150
  • #2
    tennisshoes
    Reputation
    150
View All

Related Models For Sale

Used Chevrolet Cruze
271 Great Deals out of 4,538 listings starting at $4,987
Used Ford Focus
143 Great Deals out of 2,718 listings starting at $1,100
Used Chevrolet Cobalt
27 Great Deals out of 280 listings starting at $1,389
Used Toyota Corolla
224 Great Deals out of 3,792 listings starting at $2,245
Used Honda Civic
303 Great Deals out of 3,475 listings starting at $995
Used Ford Fiesta
58 Great Deals out of 731 listings starting at $2,948
Used Nissan Versa
32 Great Deals out of 416 listings starting at $1,999
Used Chevrolet Malibu
102 Great Deals out of 2,228 listings starting at $2,994
Used Toyota Yaris
40 Great Deals out of 779 listings starting at $2,114
Used Hyundai Accent
72 Great Deals out of 1,517 listings starting at $1,288
Used Hyundai Elantra
191 Great Deals out of 3,418 listings starting at $2,488
Used Kia Rio
53 Great Deals out of 682 listings starting at $4,495
Used Ford Fusion
163 Great Deals out of 2,130 listings starting at $995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.