2009 Aveo put in new (used) engine. It runs 3-4 seconds and dies. Now what?

Asked by May 09, 2017 at 06:57 PM about the 2009 Chevrolet Aveo LT

Question type: Maintenance & Repair

Put a used 2010 Aveo engine in my 2009. Both were LXV Ecotech engines. It starts up fine, runs smooth for 3-4 seconds, and dies.

Timing is spot on. Compression is about 210 psi in all cylinders. Fuel pressure is 55 psi. No apparent vacuum leaks. No codes on my scanner. No security light.

My thought is either throttle or crank relearn may be needed, but both procedures require the engine to warm up, and mine won't run long enough.

Thoughts?

No answers yet

Your Answer

Chevrolet Aveo Experts

  • #1
    Tom Demyan
    Reputation
    370
  • #2
    tennisshoes
    Reputation
    180
  • #3
    Chris Maddox
    Reputation
    160
View All

Related Models For Sale

Used Ford Focus
111 Great Deals out of 2,614 listings starting at $1,095
Used Honda Civic
315 Great Deals out of 3,574 listings starting at $1,795
Used Chevrolet Cobalt
36 Great Deals out of 300 listings starting at $1,190
Used Chevrolet Spark
15 Great Deals out of 400 listings starting at $4,495
Used Ford Fiesta
48 Great Deals out of 753 listings starting at $2,995
Used Toyota Corolla
275 Great Deals out of 4,101 listings starting at $1,400
Used Chevrolet Malibu
112 Great Deals out of 1,909 listings starting at $3,485
Used Nissan Versa
60 Great Deals out of 463 listings starting at $1,800
Used Hyundai Accent
91 Great Deals out of 1,497 listings starting at $700
Used Toyota Yaris
35 Great Deals out of 781 listings starting at $2,000
Used Kia Rio
33 Great Deals out of 729 listings starting at $4,395
Used Toyota Camry
88 Great Deals out of 2,309 listings starting at $2,495
Used Honda Accord
89 Great Deals out of 1,026 listings starting at $750

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.