Ecm-1 fuse keeps blowing

Asked by Apr 27, 2017 at 10:36 PM about the 1997 Chevrolet C/K 1500 Silverado Extended Cab SB 4WD

Question type: Maintenance & Repair

If I held the gas at one spot for about 4
seconds it would start running bad like it
was flooding out but if i let off and have it
gas again it it will run right for about 4
seconds or i could floor it and it will run fine
untill i let off then it just up and started
running better and I seen my ecm-1 fuse
blow so I put a new one in and it started
running bad again so I pulled it back out and
it's running ok and whatever is causing it is
killing my has miles can someone plz help
me???

1 Answer

And I see where everyone else is saying there truck just died and wouldn't crank back up but mine is still running even with out it it just runs bad when the fuse is in and it's a good fuse

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    3,550
  • #2
    John Saffrahn
    Reputation
    2,550
  • #3
    Rowefast
    Reputation
    2,150
View All

Related Models For Sale

Used GMC Sierra 1500
224 Great Deals out of 10,442 listings starting at $2,995
Used Ford F-150
459 Great Deals out of 9,063 listings starting at $922
Used Dodge Ram 1500
62 Great Deals out of 528 listings starting at $2,995
Used Chevrolet Tahoe
6 Great Deals out of 632 listings starting at $6,871
Used Toyota Tacoma
27 Great Deals out of 794 listings starting at $5,995
Used Chevrolet Camaro
796 listings starting at $10,000
Used Chevrolet S-10
13 listings starting at $3,800

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.