Power plug &lighter didn't work

Asked by Mar 20, 2017 at 10:56 AM about the 2000 Buick LeSabre Custom Sedan FWD

Question type: General

Fuses under hood are good

2 Answers

1,750

Sometimes foreign material get into the plug and insulates the power point. Disconnect the battery and use a eraser or something like that to clean the contact, vacuum out the hole and see if it works.

7,985

Double check fuse. It's fuse #23 and it's a 20amp. If fuse is good, check for voltage at the plug. If fuse is good but still no power at the plug, check to make sure wires feeding the plug didn't come loose. If both wires, hot and ground are connected, trace wires back to fuse block, you may have a bad connection under fuse block

Your Answer

Buick LeSabre Experts

  • #1
    Tom Demyan
    Reputation
    2,360
  • #2
    John Saffrahn
    Reputation
    2,060
  • #3
    Austin Gaboda
    Reputation
    1,480
View All

Related Models For Sale

Used Chevrolet Impala
179 Great Deals out of 1,062 listings starting at $2,454
Used Buick Regal
3 Great Deals out of 234 listings starting at $7,495
Used Buick Century
10 listings
Used Cadillac DeVille
16 listings starting at $3,995
Used Honda Accord
69 Great Deals out of 1,187 listings starting at $1,888
Used Toyota Camry
90 Great Deals out of 2,220 listings starting at $1,900
Used Ford F-150
637 Great Deals out of 9,058 listings starting at $1,995
Used Chevrolet Malibu
99 Great Deals out of 1,769 listings starting at $888
Used Chevrolet Tahoe
5 Great Deals out of 776 listings starting at $4,200

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.