No crank no start

Asked by Feb 14, 2017 at 03:27 PM about the 2001 Buick Century Custom Sedan FWD

Question type: Maintenance & Repair

My car was running fine then the horn went
sounding off. I pulled it over as soon as i out
it in park ny car shut off and then i wouldnt
start anymore no noise. Lights work just fine
bright and everything, no horn though that
does not work. What could be wrong with
my car please help this is my only way

3 Answers


Your neutral safety switch might still be activated. Take your gear shift out of park, then put it back into park. Then try it.

1 of 1 people found this helpful.

I've done that still nothing i've tried to get a boost i've changed the fuses all new but still nothing is happening.


Do the dash board cluster lights flash when you try to start it?

Your Answer


Looking for a Used Century in your area?

CarGurus has 10 nationwide Century listings and the tools to find you a great deal.

Postal Code:

Buick Century Experts

  • #1
    John Saffrahn
  • #2
    Tom Demyan
  • #3
    John Pate
View All

Related Models For Sale

Used Buick LeSabre
10 listings starting at $3,795
Used Buick Regal
6 Great Deals out of 229 listings starting at $6,495
Used Chevrolet Impala
151 Great Deals out of 1,105 listings starting at $2,488
Used Chevrolet Malibu
72 Great Deals out of 1,820 listings starting at $2,900
Used Toyota Camry
37 Great Deals out of 1,923 listings starting at $1,995
Used Honda Accord
59 Great Deals out of 1,237 listings starting at $1,350
Used Chevrolet Monte Carlo
15 listings starting at $4,995
Used Honda Civic
251 Great Deals out of 4,533 listings starting at $2,495
Used Ford Taurus
39 Great Deals out of 330 listings starting at $5,555
Used Pontiac Grand Prix
58 listings starting at $8,950

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.