98 cabrio no start after fuel pump replacement

Asked by Jul 16, 2017 at 06:29 PM about the 1998 Volkswagen Cabrio 2 Dr GL Convertible

Question type: Maintenance & Repair

Fuel pump went out on the 98 cabrio. Replaced pump and drove approx 10 miles, ran awesome, then died like pump was out again. No voltage to pump at pump itself- Relay and fuses are good. No ground signal coming from ECU for initial prime. Any ideas? Thanks

1 Answer


well i would start going over the wiring harnesses and try to find see if any grounds or wires have any signs of corrosion other wise i would say the pump likely was a bad one. its not uncomman to get a new part and it to be bad. i went threw 4 alrenators from one company before giving up and going else ware since the company that rebuilt the alternators was just slaping what ever parts they could into them.

Your Answer

Volkswagen Cabrio Experts

  • #1
    Tom Demyan
  • #2
    Mike Bonnell
  • #3
View All

Related Models For Sale

Used Volkswagen Beetle
32 Great Deals out of 419 listings starting at $995
Used Volkswagen Jetta
105 Great Deals out of 2,126 listings starting at $2,411
Used Volkswagen Golf
74 Great Deals out of 1,145 listings starting at $2,333
Used Volkswagen GTI
15 Great Deals out of 245 listings starting at $4,450
Used Ford Mustang
1,034 listings starting at $3,900
Used Jeep Wrangler
104 Great Deals out of 2,159 listings starting at $7,477
Used Volkswagen Passat
53 Great Deals out of 909 listings starting at $3,500
Used BMW 3 Series
133 Great Deals out of 2,112 listings starting at $2,495
Used Chevrolet Camaro
1,075 listings starting at $12,995
Used BMW 5 Series
28 Great Deals out of 619 listings starting at $3,695
Used Mazda MX-5 Miata
237 listings starting at $9,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.