2000 Blazer 4wd not working

Asked by Jun 10, 2017 at 05:25 PM about the 2000 Chevrolet Blazer 2 Door LS 4WD

Question type: Maintenance & Repair

I bought a 2000 4wd Blazer a couple months ago.
It has the 4.3 vortec engine and push button 4wd.
When I put it in neutral and press "auto 4wd" the
light just flashes endlessly. When I press 4Hi, the
light doesn't come on at all, but when I press 4Lo
you can here the "clank" of the 4 lo, and the light
stays on constantly for 4lo, but it's not pulling. I'm
not very educated with 4wd vehicles as this is only
the 2nd one I've owned and never had any issues
to fix with the first one. Could someone please
point me in the right path towards making my 4wd
work?

No answers yet

Your Answer

Chevrolet Blazer Experts

  • #1
    Andrew Olsen
    Reputation
    2,030
  • #2
    yetilikesbeer
    Reputation
    1,330
  • #3
    Rowefast
    Reputation
    1,030
View All

Related Models For Sale

Used Chevrolet Tahoe
5 Great Deals out of 645 listings starting at $6,871
Used Chevrolet S-10
14 listings starting at $3,800
Used Chevrolet Silverado 1500
186 Great Deals out of 10,682 listings starting at $2,500
Used GMC Jimmy
16 listings starting at $1,980
Used Ford Explorer
42 Great Deals out of 1,369 listings starting at $3,900
Used Chevrolet Camaro
783 listings starting at $12,995
Used Jeep Grand Cherokee
80 Great Deals out of 2,679 listings starting at $1,871
Used Jeep Wrangler
98 Great Deals out of 1,570 listings starting at $1,988
Used Jeep Cherokee
118 Great Deals out of 6,097 listings starting at $11,990
Used Ford F-150
443 Great Deals out of 9,125 listings starting at $3,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.