Why is my S-10 running bad all of a sudden?

Asked by Jun 09, 2017 at 01:44 PM about the 2001 Chevrolet S-10 2 Dr LS Extended Cab SB

Question type: Maintenance & Repair

i've replaced cam sensor, distributor, cap, MAF sensor, checked plugs, and
wires. checked coil, changed TPS sensor. I just dont know where to look. I
put the scanner on before , and after. Before it said misfire multiple
cylinder, and would not run without holding the throttle on. Then i had no
misfires, and still wouldnt idle. Now i have misfires, and it idles, but still
doesnt run good at all. any suggestions?

No answers yet

Your Answer

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,370
  • #2
    Trebor66
    Reputation
    1,020
  • #3
    John Saffrahn
    Reputation
    1,000
View All

Related Models For Sale

Used Ford Ranger
65 Great Deals out of 335 listings starting at $3,900
Used Chevrolet Silverado 1500
157 Great Deals out of 10,639 listings starting at $100
Used GMC Sonoma
6 listings
Used Toyota Tacoma
28 Great Deals out of 801 listings starting at $5,995
Used Ford F-150
454 Great Deals out of 9,150 listings starting at $922
Used Dodge Dakota
11 Great Deals out of 165 listings starting at $1,948
Used Chevrolet Blazer
15 listings starting at $1,750
Used Nissan Frontier
8 Great Deals out of 409 listings starting at $6,450
Used GMC Sierra 1500
226 Great Deals out of 10,358 listings starting at $2,995
Used Dodge Ram 1500
59 Great Deals out of 533 listings starting at $2,995
Used Chevrolet Camaro
791 listings starting at $13,040
Used Toyota Tundra
21 Great Deals out of 792 listings starting at $3,999

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.