My Chevy s10 park lights for the front and rear are not working but all my other lights work and my fuses blow as soon as i put them in and the lights are all good how can i fix this?

Asked by May 15, 2018 at 12:02 PM about the 2001 Chevrolet S-10 LS Crew Cab 4WD

Question type: Maintenance & Repair

S10 does not have working park lights for the front and rear and as soon as i
replace the fuse in blows no matter the size.

No Answers Yet

Your Answer:

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,900
  • #2
    Trebor66
    Reputation
    1,160
  • #3
    Js08016
    Reputation
    1,130
View All

Related Models For Sale

Used Ford Ranger
11 Great Deals out of 290 listings starting at $1,200
Used Chevrolet Silverado 1500
98 Great Deals out of 11,118 listings starting at $4,950
Used GMC Sonoma
8 listings starting at $4,450
Used Toyota Tacoma
12 Great Deals out of 1,747 listings starting at $6,413
Used Ford F-150
136 Great Deals out of 11,442 listings starting at $1,995
Used Dodge Dakota
4 Great Deals out of 130 listings starting at $4,795
Used Chevrolet Blazer
18 listings
Used Nissan Frontier
8 Great Deals out of 438 listings starting at $3,700
Used GMC Sierra 1500
76 Great Deals out of 10,343 listings starting at $2,495
Used Dodge Ram 1500
25 Great Deals out of 525 listings starting at $4,300
Used Chevrolet Camaro
12 Great Deals out of 939 listings starting at $11,500

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.