have a lean condition on both banks 1&2

Asked by Mar 14, 2017 at 05:49 PM about the 2000 Chevrolet S-10 2 Dr LS Standard Cab LB

Question type: Maintenance & Repair

i have replaced air and fuel filters truck starts and runs fine when engine is hot
but when its cold its very hard to start

2 Answers

77,815

If you have a lean condition, then check for vacuum leaks, especially along the intake manifold.

1 of 1 people found this helpful.

thank u i will try that before i go to the oxygem sensors

Your Answer

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,590
  • #2
    John Saffrahn
    Reputation
    1,060
  • #3
    Trebor66
    Reputation
    1,050
View All

Related Models For Sale

Used Chevrolet Silverado 1500
169 Great Deals out of 10,258 listings starting at $2,230
Used Ford Ranger
67 Great Deals out of 336 listings starting at $1,995
Used Toyota Tacoma
25 Great Deals out of 1,189 listings starting at $4,444
Used GMC Sonoma
10 listings starting at $5,895
Used Ford F-150
637 Great Deals out of 9,058 listings starting at $1,995
Used Chevrolet Blazer
11 listings starting at $4,960
Used Dodge Dakota
7 Great Deals out of 143 listings starting at $1,500
Used Nissan Frontier
38 Great Deals out of 603 listings starting at $5,499
Used GMC Sierra 1500
238 Great Deals out of 10,311 listings starting at $1,775
Used Chevrolet Camaro
927 listings starting at $12,498
Used Dodge Ram 1500
40 Great Deals out of 451 listings starting at $3,488

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.