1999 S10 4.3 Vortec Initial start, but won't run.

Asked by Oct 14, 2018 at 06:04 PM about the 1999 Chevrolet S-10 LS Extended Cab 4WD

Question type: Maintenance & Repair

I have a 1999 S10, 4.3 Vortec. It will fire at first, then won't run. I have installed
new fuel pump, Relay, and Regulator. Get 60lb's, and bleeds to around 50lb's
after pump runs.

1 Answer

69,705

Faulty ignition coil, mass airflow sensor, fuel pump. Your car has an ignition or fuel pump problem. You're either not getting proper fuel or spark. Really could be either. The car should be giving you codes that tell you what part of the car is defective. You just have to get the car to a car parts store or to a dealer for the codes to be read.

Your Answer:

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    5,580
  • #2
    Js08016
    Reputation
    2,130
  • #3
    Trebor66
    Reputation
    1,980
View All

Find great deals from top-rated dealersTM

Search

Related Models For Sale

Used Chevrolet Silverado 1500
103 Great Deals out of 13,693 listings starting at $3,995
Used Ford Ranger
9 Great Deals out of 998 listings starting at $3,950
Used Toyota Tacoma
27 Great Deals out of 1,372 listings starting at $4,867
Used GMC Sonoma
1 listing
Used Ford F-150
190 Great Deals out of 14,443 listings starting at $2,000
Used Chevrolet Blazer
1,218 listings starting at $35,245
Used GMC Sierra 1500
78 Great Deals out of 12,047 listings starting at $3,995
Used Dodge Dakota
3 Great Deals out of 104 listings starting at $3,695
Used Nissan Frontier
32 Great Deals out of 677 listings starting at $3,850
Used Dodge Ram 1500
9 Great Deals out of 356 listings starting at $2,500
Used Ford Mustang
65 Great Deals out of 1,812 listings starting at $6,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.