"Service engine soon" light on even after new O2 censors?

Asked by Jun 05, 2017 at 05:15 PM about the 1996 Chevrolet S-10 2 Dr LS Standard Cab LB

Question type: Maintenance & Repair

Yep, it will go off for a few days at a time...
anybody else ever see this problem?
It almost seems like a switch/short in the electrical harness

(4.3 L)

1 Answer

I have replaced the sensors, replaced the rotted out filler neck and cap, replaced the rotted out sending unit in the tank... the light still came on, especially when the fuel level got down around 1/2 tank.... until I had my automatic trans flushed. Now the light stays off. Weird, I know, but that's what worked for me. (2.2L, 170K miles).

Your Answer

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,590
  • #2
    John Saffrahn
    Reputation
    1,060
  • #3
    Trebor66
    Reputation
    1,050
View All

Related Models For Sale

Used Ford Ranger
68 Great Deals out of 338 listings starting at $1,995
Used Toyota Tacoma
25 Great Deals out of 1,201 listings starting at $4,444
Used GMC Sonoma
10 listings starting at $5,895
Used Ford F-150
632 Great Deals out of 9,065 listings starting at $1,995
Used Chevrolet Blazer
10 listings starting at $4,960
Used Dodge Dakota
7 Great Deals out of 141 listings starting at $1,500
Used GMC Sierra 1500
239 Great Deals out of 10,212 listings starting at $1,775
Used Chevrolet Camaro
929 listings starting at $12,798
Used Dodge Ram 1500
42 Great Deals out of 452 listings starting at $3,488

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.