"Service engine soon" light on even after new O2 censors?

Asked by Jun 05, 2017 at 05:15 PM about the 1996 Chevrolet S-10 LS LB RWD

Question type: Maintenance & Repair

Yep, it will go off for a few days at a time...
anybody else ever see this problem?
It almost seems like a switch/short in the electrical harness

(4.3 L)

1 Answer

I have replaced the sensors, replaced the rotted out filler neck and cap, replaced the rotted out sending unit in the tank... the light still came on, especially when the fuel level got down around 1/2 tank.... until I had my automatic trans flushed. Now the light stays off. Weird, I know, but that's what worked for me. (2.2L, 170K miles).

Your Answer:

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,880
  • #2
    Trebor66
    Reputation
    1,150
  • #3
    Js08016
    Reputation
    1,130
View All

Related Models For Sale

Used Ford Ranger
11 Great Deals out of 287 listings starting at $1,200
Used Toyota Tacoma
13 Great Deals out of 1,720 listings starting at $6,413
Used GMC Sonoma
8 listings starting at $4,450
Used Ford F-150
142 Great Deals out of 11,520 listings starting at $1,995
Used Dodge Dakota
4 Great Deals out of 138 listings starting at $4,795
Used Chevrolet Blazer
18 listings
Used GMC Sierra 1500
79 Great Deals out of 10,243 listings starting at $4,995
Used Dodge Ram 1500
32 Great Deals out of 524 listings starting at $2,500
Used Chevrolet Camaro
11 Great Deals out of 924 listings starting at $11,500

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.