Power plugs and seat

Asked by May 17, 2018 at 09:43 PM about the 2003 Chevrolet Venture LS

Question type: General

I installed 3 more power plugs (for cell phones) and
connected them to the plug in back. They worked for
awhile and then blew a fuse inside,  replaced it.  
Happened again and I checked fuses under hood and in
the panel, all were good.  Now they and the one up front
don't work, neither does driver's power seat.  Any ideas
on what to try now?

1 Answer

181,095

You are over loading the circuit. If you need a lot of power then install a new wire/plug with fuse directly to the battery.

1 people found this helpful.

Your Answer:

Chevrolet Venture Experts

  • #1
    John Carson
    Reputation
    640
  • #2
    Reelin68
    Reputation
    520
  • #3
    CaptPKelly
    Reputation
    410
View All

Related Models For Sale

Used BMW 3 Series
115 Great Deals out of 2,281 listings starting at $2,600
Used Dodge Grand Caravan
105 Great Deals out of 10,542 listings starting at $2,489
Used Honda Odyssey
17 Great Deals out of 1,415 listings starting at $2,590
Used Jeep Grand Cherokee
59 Great Deals out of 4,903 listings starting at $3,499
Used Mercedes-Benz S-Class
8 Great Deals out of 179 listings starting at $6,480
Used Chrysler Town & Country
16 Great Deals out of 390 listings starting at $3,995
Used Toyota Sienna
33 Great Deals out of 1,239 listings starting at $2,600
Used Chevrolet Impala
32 Great Deals out of 1,001 listings starting at $1,495
Used Toyota Prius
7 Great Deals out of 274 listings starting at $1,995
Used Honda CR-V
67 Great Deals out of 4,287 listings starting at $3,299

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.