I have a 2005 ford 500 with 80K miles. The vents on the passenger side will not blow either hot or cold air. I think it needs freon because the two vents on the driver side blow but no a/c - only hot air. Is this a compressor problem?

Asked by Jun 14, 2017 at 11:01 PM about the 2005 Ford Five Hundred Limited

Question type: Maintenance & Repair

1 Answer

32,565

Have the refrigerant pressure measured, you won't know if it's low until you do. If it's real low, then it likely leaked out and you need to have that leak repaired, then recharged. (BTW freon is no longer used, you have r134a in your vehicle.)

Your Answer

Ford Five Hundred Experts

  • #1
    jonnyboii
    Reputation
    690
  • #2
    Tom Demyan
    Reputation
    670
  • #3
    dvigano
    Reputation
    610
View All

Related Models For Sale

Used Ford Taurus
35 Great Deals out of 322 listings starting at $4,988
Used Ford Fusion
110 Great Deals out of 1,726 listings starting at $1,995
Used Chevrolet Impala
141 Great Deals out of 1,103 listings starting at $1,995
Used Ford Mustang
991 listings starting at $3,900
Used Honda Accord
47 Great Deals out of 1,209 listings starting at $1,795
Used Ford Explorer
39 Great Deals out of 1,606 listings starting at $4,995
Used Ford Focus
82 Great Deals out of 2,487 listings starting at $990
Used Ford Escape
180 Great Deals out of 4,729 listings starting at $1,995
Used Ford F-150
616 Great Deals out of 9,527 listings starting at $2,500
Used Chevrolet Malibu
84 Great Deals out of 1,809 listings starting at $2,495
Used Toyota Camry
48 Great Deals out of 2,120 listings starting at $2,750
Used Chrysler 300
86 Great Deals out of 828 listings starting at $1,888

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.