Rough idle and sputtering/hestation when accelerating

Asked by Jhicks91 Oct 13, 2017 at 06:01 AM about the 2006 Ford Expedition Eddie Bauer 4WD

Question type: Maintenance & Repair

The vehicle is a 2006 ford expedition 5.7l 4x4 with
144k miles. When I first start it up it will run fine
and accelerate fine until I get around 30mph then I
get a power loss and the hesitation.  After that
when I stop the idle is rough and sounds like it
might be misfiring.  

2 Answers

18,585

check plugs and wires , scan for codes even if the light ain't on

2 people found this helpful.
110

When i first crank up my 2003 ford expedition 5.4 it run rough. I take off and accelerate and when i get to 30 miles an hour it bogs down and then it dies on me what can it be.

11 people found this helpful.

Your Answer:

Ford Expedition Experts

  • #1
    T_S_T
    Reputation
    3,620
  • #2
    Larry Sturgis
    Reputation
    3,490
  • #3
    F_O_R
    Reputation
    2,090
View All

Find great deals from top-rated dealers

Search

Related Models For Sale

Used Toyota Sequoia
8 Great Deals out of 151 listings starting at $8,999
Used Honda Pilot
44 Great Deals out of 1,512 listings starting at $3,799
Used Chevrolet Tahoe
14 Great Deals out of 646 listings starting at $4,995

Used Cars for Sale

2020 Ford Expedition For Sale
398 listings starting at $62,500
2019 Ford Expedition For Sale
84 listings starting at $50,990
2018 Ford Expedition For Sale
36 listings starting at $35,999
2017 Ford Expedition For Sale
43 listings starting at $27,777
2016 Ford Expedition For Sale
18 listings starting at $23,777

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.