Car MAF not functioning properly

Asked by Aug 12, 2017 at 01:00 PM about the 1995 Ford Crown Victoria 4 Dr LX Sedan

Question type: Maintenance & Repair

My check engine light came on it said the air and
fuel was too lean and that the MAF sensor was off, i cleaned it already but the problem persists. When
i open the hood it sounds like air is escaping, like if
theres an air leak. The guy at autozone told me
that could make the code read as if the MAF is not
functioning properly. Is there a way to check which
hoes is the air escaping from or if thats even the
problem? Thank you.

2 Answers

76,955

Look for loose vacuum hoses or hoses that have cracks in them. https://www.2carpros.com/articles/how-to-use-an-engine-vacuum- gauge

1 of 1 people found this helpful.
76,955

A bad O2 sensor can also cause the "too lean" warning.

1 of 1 people found this helpful.

Your Answer

Ford Crown Victoria Experts

  • #1
    Tracy Hooks
    Reputation
    1,860
  • #2
    Tom Demyan
    Reputation
    1,080
  • #3
    tennisshoes
    Reputation
    750
View All

Related Models For Sale

Used Ford Mustang
5 Great Deals out of 1,117 listings starting at $1,250
Used Ford Taurus
17 Great Deals out of 319 listings starting at $4,900
Used Lincoln Town Car
19 listings starting at $1,850
Used Chevrolet Impala
139 Great Deals out of 1,037 listings starting at $1,500
Used Ford Explorer
50 Great Deals out of 1,446 listings starting at $2,800
Used Ford F-150
523 Great Deals out of 10,166 listings starting at $3,450
Used Chevrolet Tahoe
6 Great Deals out of 725 listings starting at $4,995
Used Chevrolet Camaro
810 listings starting at $13,404

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.