Car MAF not functioning properly

Asked by Aug 12, 2017 at 01:00 PM about the 1995 Ford Crown Victoria 4 Dr LX Sedan

Question type: Maintenance & Repair

My check engine light came on it said the air and
fuel was too lean and that the MAF sensor was off, i cleaned it already but the problem persists. When
i open the hood it sounds like air is escaping, like if
theres an air leak. The guy at autozone told me
that could make the code read as if the MAF is not
functioning properly. Is there a way to check which
hoes is the air escaping from or if thats even the
problem? Thank you.

2 Answers

83,265

Look for loose vacuum hoses or hoses that have cracks in them. https://www.2carpros.com/articles/how-to-use-an-engine-vacuum- gauge

1 of 1 people found this helpful.
83,265

A bad O2 sensor can also cause the "too lean" warning.

1 of 1 people found this helpful.

Your Answer

Ford Crown Victoria Experts

  • #1
    Tracy Hooks
    Reputation
    1,880
  • #2
    Tom Demyan
    Reputation
    1,110
  • #3
    tennisshoes
    Reputation
    800
View All

Related Models For Sale

Used Ford Taurus
22 Great Deals out of 322 listings starting at $2,100
Used Ford Mustang
14 Great Deals out of 1,156 listings starting at $4,500
Used Lincoln Town Car
20 listings starting at $1,850
Used Chevrolet Impala
112 Great Deals out of 1,118 listings starting at $996
Used Ford Explorer
49 Great Deals out of 1,688 listings starting at $3,985
Used Ford F-150
659 Great Deals out of 13,638 listings starting at $3,000
Used Chevrolet Tahoe
7 Great Deals out of 813 listings starting at $3,995
Used Chevrolet Camaro
916 listings starting at $12,000
Used Honda Accord
88 Great Deals out of 1,118 listings starting at $750

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.