uh hello my name is pete im new to car gurus forum have a no electric fan on my 1995 chevy monte carlo z34 3.4 liter replaced coolant temp sensor, temp gauge switch, did the relay test by passing battery power to relay. replaced ecm still fans will not come oneven when i let run up to 250 degrees anyone have any input on this new water pump as well im stumped also meticulously bled the system im dumbfounded

Asked by Jul 29, 2017 at 10:46 PM about the 1995 Chevrolet Monte Carlo Z34 FWD

Question type: Maintenance & Repair

1 Answer

7,485

hot wire the fans to see if they work , the blades can get razor sharp be careful probing around there

Your Answer:

Chevrolet Monte Carlo Experts

  • #1
    Js08016
    Reputation
    600
  • #2
    John Saffrahn
    Reputation
    500
  • #3
    tenspeed
    Reputation
    420
View All

Related Models For Sale

Used Chevrolet Impala
19 Great Deals out of 883 listings starting at $2,894
Used Chevrolet Camaro
10 Great Deals out of 932 listings starting at $11,500
Used Ford Mustang
41 Great Deals out of 1,238 listings starting at $3,995
Used Chevrolet Corvette
7 Great Deals out of 525 listings starting at $9,950
Used Chevrolet Tahoe
11 Great Deals out of 782 listings starting at $5,900
Used Pontiac Firebird
27 listings starting at $12,999
Used Buick Regal
3 Great Deals out of 140 listings starting at $6,988

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.