Bakkie hardstarting

Asked by Jan 29, 2017 at 11:36 AM

Question type: General

My 2.2 tata xenon ( same as safari) had
hardstarting about 3 weeks ago then i did
numerious test on checking what wrong . It
wil crank about 3 turn before starting. I
replace the batterie and have checked the
altenator aswell. Took egr valve off checked
working order also the vacuum. Put new
airfilter and replace 2 feulfilters. Also clean
feullines replace bubble pump with electrical
one. Also replace glowplugs.took vehicle for
fault code reading after saw red engine light
come on and that happen only after driving a
while and push bakkie to overtake
somebody or going uphill the revs go down
to 2.5 no more above it like it went into
limpmode. U have to release accelerator a
bit then red engine light will go off . After
reading of fault code shows 1) rail pressure
low feul pressure error positive
2) rail pressure high feul pressire error
negative
Been told feulmetering vave faulty . Took
feul metering solenoid of behind feul pump
check working order clean an put back. Now
the engine crank about 20 turns then
start!!!!! And now it make hell of black
smoke after started and i rev it it make black
smoke. What is wrong???? Must i replace
the metering valve or what what other valve
or swithes is on the pump??? Thanks derrick

No answers yet

Your Answer

Shortcuts

Tata Experts

  • #1
    Yoandev
    Reputation
    400
  • #2
    Toloane
    Reputation
    390
  • #3
    Nico Snymann
    Reputation
    330
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.