1998 S10 lack of power when going up a steep bridge at 70mph slowly lost speed even when I gave it more gas nothing happened. It blows white steam like smoke that disappears instantly. There is also water coming from tailpipe i know there will be some water but it seems to be a little more than normal. Any ideas on what could be the cause and how to repair this problem . Thanks

Asked by Jan 09, 2018 at 05:32 PM

Question type: Maintenance & Repair

1998 S10  lack of power when going up a steep bridge at 70mph slowly lost
speed even when I gave it more gas nothing happened. It blows white steam
like smoke that disappears instantly. There is also water coming from tailpipe i
know there will be some water but it seems to be a little more than normal. Any
ideas on what could be the cause and how to repair this problem . Thanks

4 Answers

150,105

Bad head gasket.

Best Answer Mark helpful

Could it be clogged converter or exhaust.i was told if it was head gasket that the oil would be milky (which looks fine) and if I pulled spark plugs and 1 or more were clean ,then I was getting water in cylinder but all plugs look like normal wear on them.also the lack of power sound like a clogged converter\exhaust problem

150,105

Water does not always get into the oil. It cannot hurt to check the cat.

What's the best way to check?

Your Answer:

Maintenance & Repair Experts

  • #1
    dandyoun
    Reputation
    110,240
  • #2
    tennisshoes
    Reputation
    103,250
  • #3
    tenspeed
    Reputation
    86,950
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.